summaryrefslogtreecommitdiff
path: root/packages/vera-fonts/ttf-bitstream-vera_1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/vera-fonts/ttf-bitstream-vera_1.10.bb')
-rw-r--r--packages/vera-fonts/ttf-bitstream-vera_1.10.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/vera-fonts/ttf-bitstream-vera_1.10.bb b/packages/vera-fonts/ttf-bitstream-vera_1.10.bb
index e69de29bb2..11b87768ae 100644
--- a/packages/vera-fonts/ttf-bitstream-vera_1.10.bb
+++ b/packages/vera-fonts/ttf-bitstream-vera_1.10.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The Bitstream Vera fonts - TTF Edition"
+SECTION = "x11/fonts"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ttf-bitstream-vera/1.10/ttf-bitstream-vera-${PV}.tar.bz2"
+
+do_install () {
+ install -d ${D}${prefix}/share/fonts/ttf/
+ for i in *.ttf; do
+ install -m 644 $i ${D}${prefix}/share/fonts/ttf/${i}
+ done
+
+ # fontconfig ships this too. not sure what to do about it.
+ #install -d ${D}/etc/fonts
+ #install -m 644 local.conf ${D}/etc/fonts/local.conf
+
+
+ install -d ${D}${prefix}/share/doc/${PN}/
+ for i in *.TXT; do
+ install -m 644 $i ${D}${prefix}/share/doc/${PN}/$i
+ done
+}
+
+pkg_postinst () {
+#!/bin/sh
+fc-cache
+}
+
+PACKAGE_ARCH = "all"
+
+FILES_${PN} = "/etc /usr/share/fonts"