summaryrefslogtreecommitdiff
path: root/packages/upstart
diff options
context:
space:
mode:
Diffstat (limited to 'packages/upstart')
-rw-r--r--packages/upstart/.mtn2git_empty0
-rw-r--r--packages/upstart/files/.mtn2git_empty0
-rw-r--r--packages/upstart/files/autoconf_version.patch12
-rw-r--r--packages/upstart/upstart.inc26
-rw-r--r--packages/upstart/upstart_0.3.8.bb7
5 files changed, 45 insertions, 0 deletions
diff --git a/packages/upstart/.mtn2git_empty b/packages/upstart/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/upstart/.mtn2git_empty
diff --git a/packages/upstart/files/.mtn2git_empty b/packages/upstart/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/upstart/files/.mtn2git_empty
diff --git a/packages/upstart/files/autoconf_version.patch b/packages/upstart/files/autoconf_version.patch
new file mode 100644
index 0000000000..73b19879fb
--- /dev/null
+++ b/packages/upstart/files/autoconf_version.patch
@@ -0,0 +1,12 @@
+Index: upstart-0.3.8/configure.ac
+===================================================================
+--- upstart-0.3.8.orig/configure.ac 2007-05-09 22:02:14.000000000 +0200
++++ upstart-0.3.8/configure.ac 2007-05-09 22:02:24.000000000 +0200
+@@ -1,6 +1,6 @@
+ # Process this file with autoconf to produce a configure script.
+
+-AC_PREREQ(2.60)
++AC_PREREQ(2.59)
+ AC_INIT([upstart], [0.3.8], [upstart-devel@lists.ubuntu.com])
+ AC_COPYRIGHT([[Copyright © 2007 Canonical Ltd.]])
+ AC_CONFIG_SRCDIR([init/main.c])
diff --git a/packages/upstart/upstart.inc b/packages/upstart/upstart.inc
new file mode 100644
index 0000000000..59f21c9ed5
--- /dev/null
+++ b/packages/upstart/upstart.inc
@@ -0,0 +1,26 @@
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = ""
+DESCRIPTION = "Event driven system init"
+LICENSE = "GPL"
+
+inherit autotools pkgconfig
+
+# --enable-compat builds halt, reboot, shutdown tools
+EXTRA_OECONF += "--enable-compat"
+
+do_stage () {
+ autotools_stage_all
+}
+
+# libupstart can be used for upstart event generation from other programs.
+# However it is not used by upstart itself, so package it seperately.
+PACKAGES =+ "libupstart libupstart-dev"
+FILES_libupstart += "${libdir}/libupstart.so.*"
+FILES_libupstart-dev += "${libdir}/libupstart.* ${includedir}/upstart/"
+
+# upstart-sysvcompat provides Sys V Init compatible tools: halt, reboot,
+# shutdown, telinit. These might be needed by other scripts.
+PACKAGES =+ "upstart-sysvcompat upstart-sysvtools-doc"
+FILES_upstart-sysvcompat += "${sbindir}/reboot ${sbindir}/halt ${sbindir}/shutdown ${sbindir}/telinit"
+FILES_upstart-sysvcompat-doc += "${mandir}/*/reboot.* ${mandir}/*/halt.* ${mandir}/*/shutdown.* ${mandir}/*/telinit.*"
diff --git a/packages/upstart/upstart_0.3.8.bb b/packages/upstart/upstart_0.3.8.bb
new file mode 100644
index 0000000000..5a4cf872a8
--- /dev/null
+++ b/packages/upstart/upstart_0.3.8.bb
@@ -0,0 +1,7 @@
+require upstart.inc
+
+SRC_URI = "http://upstart.ubuntu.com/download/0.3/upstart-${PV}.tar.bz2 \
+file://autoconf_version.patch;patch=1"
+
+PR = "r1"
+