summaryrefslogtreecommitdiff
path: root/packages/units/units-1.80
diff options
context:
space:
mode:
Diffstat (limited to 'packages/units/units-1.80')
-rw-r--r--packages/units/units-1.80/makefile.patch73
-rw-r--r--packages/units/units-1.80/units.c.patch19
2 files changed, 0 insertions, 92 deletions
diff --git a/packages/units/units-1.80/makefile.patch b/packages/units/units-1.80/makefile.patch
deleted file mode 100644
index 376e58fdb3..0000000000
--- a/packages/units/units-1.80/makefile.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- units-1.80/Makefile.in~makefile 2002-05-03 02:15:08.000000000 +0100
-+++ units-1.80/Makefile.in 2003-11-04 16:53:31.000000000 +0000
-@@ -26,6 +26,7 @@
- srcdir = @srcdir@
-
- CC = @CC@
-+DESTDIR =
-
- INSTALL = @INSTALL@
- INSTALL_DATA = @INSTALL_DATA@
-@@ -95,19 +96,19 @@
- $(CC) $(LDFLAGS) -o units $(OBJECTS) parse.tab.o getopt.o getopt1.o @STRFUNC@ $(LIBS)
-
- install: units units.dat install-doc
-- $(srcdir)/mkinstalldirs $(bindir) $(datadir)
-- $(INSTALL_PROGRAM) units $(bindir)/`echo units|sed '$(transform)'`
-- $(INSTALL_DATA) $(srcdir)/units.dat $(datadir)/units.dat
-+ $(srcdir)/mkinstalldirs $(DESTDIR)/$(bindir) $(datadir)
-+ $(INSTALL_PROGRAM) units $(DESTDIR)/$(bindir)/`echo units|sed '$(transform)'`
-+ $(INSTALL_DATA) $(srcdir)/units.dat $(DESTDIR)/$(datadir)/units.dat
-
- install-strip: units units.dat install-doc
-- $(INSTALL_PROGRAM) -s units $(bindir)/`echo units|sed '$(transform)'`
-- $(INSTALL_DATA) $(srcdir)/units.dat $(datadir)/units.dat
-+ $(INSTALL_PROGRAM) -s units $(DESTDIR)/$(bindir)/`echo units|sed '$(transform)'`
-+ $(INSTALL_DATA) $(srcdir)/units.dat $(DESTDIR)/$(datadir)/units.dat
-
- install-doc: install-man install-info
-
- install-man: units.1
-- $(srcdir)/mkinstalldirs $(mandir)/man1
-- $(INSTALL_DATA) units.1 $(mandir)/man1/`echo units|sed '$(transform)'`.1
-+ $(srcdir)/mkinstalldirs $(DESTDIR)/$(mandir)/man1
-+ $(INSTALL_DATA) units.1 $(DESTDIR)/$(mandir)/man1/`echo units|sed '$(transform)'`.1
-
- units.man: units.texinfo texi2man
- ./texi2man units.texinfo > units.man
-@@ -115,10 +116,10 @@
- units.1: units.man
- sed s!@DATAFILE@!@UDAT@units.dat! $(srcdir)/units.man > units.1
-
--install-info: $(infodir)/units.info
-+install-info: $(DESTDIR)/$(infodir)/units.info
-
--$(infodir)/units.info: units.info
-- $(srcdir)/mkinstalldirs $(infodir)
-+$(DESTDIR)/$(infodir)/units.info: units.info
-+ $(srcdir)/mkinstalldirs $(DESTDIR)/$(infodir)
- # There may be a newer info file in . than in srcdir.
- -if test -f units.info; then d=.; \
- else d=$(srcdir); fi; \
-@@ -128,11 +129,11 @@
- # line so we notice real errors from install-info.
- # We use `$(SHELL) -c' because some shells do not
- # fail gracefully when there is an unknown command.
-- if test -f $(infodir)/dir; then \
-+ if test -f $(DESTDIR)/$(infodir)/dir; then \
- if $(SHELL) -c 'install-info --version' \
- >/dev/null 2>&1; then \
-- install-info --dir-file=$(infodir)/dir \
-- $(infodir)/units.info; \
-+ install-info --dir-file=$(DESTDIR)/$(infodir)/dir \
-+ $(DESTDIR)/$(infodir)/units.info; \
- else true; fi \
- else true; fi
-
---- units-1.80/vim~makefile
-+++ units-1.80/vim
diff --git a/packages/units/units-1.80/units.c.patch b/packages/units/units-1.80/units.c.patch
deleted file mode 100644
index 55867ba5e3..0000000000
--- a/packages/units/units-1.80/units.c.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- units-1.80/units.c~units.c 2003-11-04 16:45:07.000000000 +0000
-+++ units-1.80/units.c 2003-11-04 16:45:54.000000000 +0000
-@@ -2356,11 +2356,3 @@
- crude example to convert lines in a file 'feet' from ft to m might be:
- */
-
--#if 0
--
-- "sed 's/.*/& ft\"
-- "m/' feet|units -q|sed 's/^[[:space:]]*\* //"
-- "/^[[:space:]]*\//d'"
--
--#endif
--