summaryrefslogtreecommitdiff
path: root/packages/udev/udev_070.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/udev/udev_070.bb')
-rw-r--r--packages/udev/udev_070.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/udev/udev_070.bb b/packages/udev/udev_070.bb
new file mode 100644
index 0000000000..3fd3c3f522
--- /dev/null
+++ b/packages/udev/udev_070.bb
@@ -0,0 +1,27 @@
+SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
+ file://tmpfs.patch;patch=1 \
+ file://noasmlinkage.patch;patch=1 \
+ file://flags.patch;patch=1 \
+ file://tty-symlinks.patch;patch=1 \
+ file://udev.rules \
+ file://links.conf \
+ file://init"
+
+UDEV_DEVFS_RULES = "0"
+
+include udev.inc
+
+PR = "r0"
+
+UDEV_EXTRAS = "extras/scsi_id/ extras/volume_id/ extras/run_directory/"
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/udev.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${WORKDIR}/links.conf ${D}${sysconfdir}/udev/links.conf
+}
+
+#FIXME UDEV MIGRATION PLAN:
+#FIXME a) udevd is now a netlink daemon and needs to be started by the init script (ours is way too old)
+#FIXME b) sbin/hotplug should no longer be called by the kernel, i.e. echo "" >/proc/sys/kernel/hotplug
+#FIXME done c) until d) happens, udev will emulate hotplugd behaviour (see do_install_append()
+#FIXME d) eventually hotplug should no longer be used at all, all agents shall be converted to udev rules