summaryrefslogtreecommitdiff
path: root/packages/uclibc
diff options
context:
space:
mode:
Diffstat (limited to 'packages/uclibc')
-rw-r--r--packages/uclibc/uclibc.inc2
-rw-r--r--packages/uclibc/uclibc_svn.bb20
2 files changed, 1 insertions, 21 deletions
diff --git a/packages/uclibc/uclibc.inc b/packages/uclibc/uclibc.inc
index 2064489ec6..8cd85d53d1 100644
--- a/packages/uclibc/uclibc.inc
+++ b/packages/uclibc/uclibc.inc
@@ -14,7 +14,7 @@ MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
python __anonymous () {
import bb, re
- uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
+ uc_os = (re.match('.*uclibc*', bb.data.getVar('TARGET_OS', d, 1)) != None)
if not uc_os:
raise bb.parse.SkipPackage("incompatible with target %s" %
bb.data.getVar('TARGET_OS', d, 1))
diff --git a/packages/uclibc/uclibc_svn.bb b/packages/uclibc/uclibc_svn.bb
index a12b9b99c6..c2821eb585 100644
--- a/packages/uclibc/uclibc_svn.bb
+++ b/packages/uclibc/uclibc_svn.bb
@@ -34,24 +34,4 @@ S = "${WORKDIR}/uClibc"
# have a 'good' set of kernel header files in the cross directory.
#UCLIBC_PATCHES += "file://nokernelheadercheck.patch;patch=1"
#
-# Thumb support
-UCLIBC_PATCHES += " file://thumb-defined-arm-or-thumb.patch;patch=1"
-#
-# Thumb interworking support
-UCLIBC_PATCHES += " file://thumb-mov-pc-bx.patch;patch=1"
-UCLIBC_PATCHES += " file://thumb-swi-r7.patch;patch=1"
-UCLIBC_PATCHES += " file://thumb-sysnum-h.patch;patch=1"
-UCLIBC_PATCHES += " file://thumb-asm-swi.patch;patch=1"
-UCLIBC_PATCHES += " file://thumb-call-via-rx.patch;patch=1"
-#
-# This is a core change and is controversial, maybe even wrong
-# on some architectures
-THUMB_INTERWORK_RESOLVE_PATCH = ""
-THUMB_INTERWORK_RESOLVE_PATCH_thumb-interwork = " file://thumb-resolve.patch;patch=1"
-UCLIBC_PATCHES += " ${THUMB_INTERWORK_RESOLVE_PATCH}"
-
-# Set this for non-head patches (the above list should match the
-# requirements of the SVN head).
-UCLIBC_SVN_PATCHES ?= "${UCLIBC_PATCHES}"
-SRC_URI += "${UCLIBC_SVN_PATCHES}"