summaryrefslogtreecommitdiff
path: root/packages/uboot/uboot-openmoko_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/uboot/uboot-openmoko_svn.bb')
-rw-r--r--packages/uboot/uboot-openmoko_svn.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/packages/uboot/uboot-openmoko_svn.bb b/packages/uboot/uboot-openmoko_svn.bb
index 06c15c14c2..d7a07a7d00 100644
--- a/packages/uboot/uboot-openmoko_svn.bb
+++ b/packages/uboot/uboot-openmoko_svn.bb
@@ -73,8 +73,10 @@ do_deploy () {
for mach in ${UBOOT_MACHINES}
do
install -m 0644 ${S}/u-boot_${mach}.bin ${DEPLOY_DIR_IMAGE}/u-boot-${mach}-${PV}-${PR}.bin
+ ln -sf ${DEPLOY_DIR_IMAGE}/u-boot-${mach}-${PV}-${PR}.bin ${DEPLOY_DIR_IMAGE}/uboot-${mach}-latest.bin
if [ -f ${S}/lowlevel_foo_${mach}.bin ]; then
install -m 0644 ${S}/lowlevel_foo_${mach}.bin ${DEPLOY_DIR_IMAGE}/lowlevel_foo-${mach}-${PV}-${PR}.bin
+ ln -sf ${DEPLOY_DIR_IMAGE}/lowlevel_foo-${mach}-${PV}-${PR}.bin ${DEPLOY_DIR_IMAGE}/lowlevel-foo-${mach}-latest.bin
fi
done
install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage