summaryrefslogtreecommitdiff
path: root/packages/uboot/u-boot-utils_1.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/uboot/u-boot-utils_1.2.0.bb')
-rw-r--r--packages/uboot/u-boot-utils_1.2.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/uboot/u-boot-utils_1.2.0.bb b/packages/uboot/u-boot-utils_1.2.0.bb
new file mode 100644
index 0000000000..e86fc60311
--- /dev/null
+++ b/packages/uboot/u-boot-utils_1.2.0.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "U-boot bootloader OS env. access tools"
+SECTION = "bootloaders"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS_openprotium = "mtd-utils"
+PR = "r7"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2"
+SRC_URI_append_openprotium = " \
+ file://fw_env.c.patch;patch=1 \
+ file://tools-Makefile.patch;patch=1 \
+ file://env-Makefile.patch;patch=1 \
+ file://fw_env.config"
+
+S = "${WORKDIR}/u-boot-${PV}"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/u-boot-${PV}"
+
+EXTRA_OEMAKE_openprotium = "CROSS_COMPILE=${TARGET_PREFIX}"
+
+do_configure() {
+ :
+}
+
+do_compile () {
+ oe_runmake Sandpoint8240_config
+ oe_runmake tools
+}
+
+do_install () {
+ :
+}
+
+do_install_openprotium () {
+ install -d ${D}/sbin
+ install -d ${D}${sysconfdir}
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+ install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_printenv
+ install -m 755 ${S}/tools/env/fw_printenv ${D}/sbin/fw_setenv
+}
+