summaryrefslogtreecommitdiff
path: root/packages/u-boot/u-boot_1.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/u-boot/u-boot_1.2.0.bb')
-rw-r--r--packages/u-boot/u-boot_1.2.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/u-boot/u-boot_1.2.0.bb b/packages/u-boot/u-boot_1.2.0.bb
new file mode 100644
index 0000000000..f1075bb00b
--- /dev/null
+++ b/packages/u-boot/u-boot_1.2.0.bb
@@ -0,0 +1,25 @@
+require u-boot.inc
+
+PR = "r2"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-1.2.0.tar.bz2 \
+ "
+SRC_URI_append_turbostation = "file://qnap.diff;patch=1"
+
+SRC_URI_append_lsppchg = "file://u-boot-kurobox.patch;patch=1 \
+ file://u-boot-kurobox-fdt.patch;patch=1 \
+ file://defconfig_lsppchg"
+
+SRC_URI_append_lsppchd = "file://u-boot-kurobox.patch;patch=1 \
+ file://u-boot-kurobox-fdt.patch;patch=1 \
+ file://defconfig_lsppchg"
+
+do_compile_prepend_lsppchg () {
+ cp ${WORKDIR}/defconfig_lsppchg ${S}/include/configs/linkstation.h
+}
+
+do_compile_prepend_lsppchd () {
+ cp ${WORKDIR}/defconfig_lsppchd ${S}/include/configs/linkstation.h
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"