summaryrefslogtreecommitdiff
path: root/packages/tslib
diff options
context:
space:
mode:
Diffstat (limited to 'packages/tslib')
-rw-r--r--packages/tslib/tslib/h2200/.mtn2git_empty0
-rw-r--r--packages/tslib/tslib/h2200/tslib.sh19
-rw-r--r--packages/tslib/tslib_cvs.bb2
3 files changed, 20 insertions, 1 deletions
diff --git a/packages/tslib/tslib/h2200/.mtn2git_empty b/packages/tslib/tslib/h2200/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tslib/tslib/h2200/.mtn2git_empty
diff --git a/packages/tslib/tslib/h2200/tslib.sh b/packages/tslib/tslib/h2200/tslib.sh
new file mode 100644
index 0000000000..be9448b1dc
--- /dev/null
+++ b/packages/tslib/tslib/h2200/tslib.sh
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+module_id() {
+ awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
+}
+
+case `uname -r` in
+2.4*)
+ TSLIB_TSDEVICE=/dev/touchscreen/0raw
+ TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600-2.4
+ ;;
+*)
+ TSLIB_TSDEVICE=`detect-stylus --device`
+ TSLIB_CONFFILE=/usr/share/tslib/ts.conf-h3600
+ ;;
+esac
+
+export TSLIB_TSDEVICE TSLIB_CONFFILE
+
diff --git a/packages/tslib/tslib_cvs.bb b/packages/tslib/tslib_cvs.bb
index f0267a6814..0a79a492a3 100644
--- a/packages/tslib/tslib_cvs.bb
+++ b/packages/tslib/tslib_cvs.bb
@@ -41,7 +41,7 @@ do_install_append() {
install -d ${D}${sysconfdir}/profile.d/
install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
case ${MACHINE} in
- h3600 | h3900 | h1940 | h6300 | ipaq-pxa270)
+ h3600 | h3900 | h1940 | h6300 | h2200 | ipaq-pxa270)
install -d ${D}${datadir}/tslib
for f in ts.conf-h3600 ts.conf-h3600-2.4 ts.conf-h6300; do
install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/