summaryrefslogtreecommitdiff
path: root/packages/thttpd
diff options
context:
space:
mode:
Diffstat (limited to 'packages/thttpd')
-rw-r--r--packages/thttpd/files/init47
-rw-r--r--packages/thttpd/thttpd_2.25b.bb11
2 files changed, 57 insertions, 1 deletions
diff --git a/packages/thttpd/files/init b/packages/thttpd/files/init
new file mode 100644
index 0000000000..fdcd0f4530
--- /dev/null
+++ b/packages/thttpd/files/init
@@ -0,0 +1,47 @@
+#! /bin/sh
+#
+# This is an init script for openembedded
+# Copy it to /etc/init.d/thttpd and type
+# > update-rc.d thttpd defaults 60
+#
+
+
+thttpd=/usr/sbin/thttpd
+test -x "$thttpd" || exit 0
+
+
+case "$1" in
+ start)
+ echo -n "Starting thttpd"
+ start-stop-daemon --start --quiet --exec $thttpd
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping thttpd"
+ start-stop-daemon --stop --quiet --exec $thttpd
+ echo "."
+ ;;
+ reload|force-reload)
+ start-stop-daemon --stop --quiet --signal 1 --exec $thttpd
+ ;;
+ restart)
+ echo -n "Stopping thttpd"
+ start-stop-daemon --stop --quiet --exec $thttpd
+ echo "."
+ echo -n "Waiting for thttpd to die off"
+ for i in 1 2 3 ;
+ do
+ sleep 1
+ echo -n "."
+ done
+ echo ""
+ echo -n "Starting thttpd"
+ start-stop-daemon --start --quiet --exec $thttpd
+ echo "."
+ ;;
+ *)
+ echo "Usage: /etc/init.d/thttpd {start|stop|reload|restart|force-reload}"
+ exit 1
+esac
+
+exit 0
diff --git a/packages/thttpd/thttpd_2.25b.bb b/packages/thttpd/thttpd_2.25b.bb
index b3d179a0ee..e7b786c1b0 100644
--- a/packages/thttpd/thttpd_2.25b.bb
+++ b/packages/thttpd/thttpd_2.25b.bb
@@ -2,11 +2,15 @@ DESCRIPTION = "A simple, small, portable, fast, and secure HTTP server."
LICENSE = "BSD"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
HOMEPAGE = "http://www.acme.com/software/thttpd/"
+PR="r1"
SRC_URI = "http://www.acme.com/software/thttpd/thttpd-2.25b.tar.gz \
file://install.patch;patch=1 \
- file://acinclude.m4"
+ file://acinclude.m4 \
+ file://init"
S = "${WORKDIR}/thttpd-${PV}"
+INITSCRIPT_NAME = "thttpd"
+INITSCRIPT_PARAMS = "defaults"
inherit autotools
@@ -17,3 +21,8 @@ do_configure () {
install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
autotools_do_configure
}
+
+do_install_append () {
+ install -d "${D}${sysconfdir}/init.d"
+ install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/thttpd
+}