summaryrefslogtreecommitdiff
path: root/packages/thttpd/thttpd_2.25b.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/thttpd/thttpd_2.25b.bb')
-rw-r--r--packages/thttpd/thttpd_2.25b.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/packages/thttpd/thttpd_2.25b.bb b/packages/thttpd/thttpd_2.25b.bb
index b3d179a0ee..280b2dee7e 100644
--- a/packages/thttpd/thttpd_2.25b.bb
+++ b/packages/thttpd/thttpd_2.25b.bb
@@ -5,7 +5,8 @@ HOMEPAGE = "http://www.acme.com/software/thttpd/"
SRC_URI = "http://www.acme.com/software/thttpd/thttpd-2.25b.tar.gz \
file://install.patch;patch=1 \
- file://acinclude.m4"
+ file://acinclude.m4 \
+ file://init"
S = "${WORKDIR}/thttpd-${PV}"
inherit autotools
@@ -17,3 +18,8 @@ do_configure () {
install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
autotools_do_configure
}
+
+do_install_append () {
+ install -d "${D}${sysconfdir}/init.d"
+ install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/thttpd
+}