summaryrefslogtreecommitdiff
path: root/packages/thttpd/thttpd_2.25b.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/thttpd/thttpd_2.25b.bb')
-rw-r--r--packages/thttpd/thttpd_2.25b.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/thttpd/thttpd_2.25b.bb b/packages/thttpd/thttpd_2.25b.bb
index e69de29bb2..b3d179a0ee 100644
--- a/packages/thttpd/thttpd_2.25b.bb
+++ b/packages/thttpd/thttpd_2.25b.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A simple, small, portable, fast, and secure HTTP server."
+LICENSE = "BSD"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+HOMEPAGE = "http://www.acme.com/software/thttpd/"
+
+SRC_URI = "http://www.acme.com/software/thttpd/thttpd-2.25b.tar.gz \
+ file://install.patch;patch=1 \
+ file://acinclude.m4"
+S = "${WORKDIR}/thttpd-${PV}"
+
+inherit autotools
+
+EXTRA_OEMAKE += "'WEBDIR=${servicedir}/www'"
+FILES_${PN}_append = " ${servicedir}"
+
+do_configure () {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
+}