summaryrefslogtreecommitdiff
path: root/packages/tasks
diff options
context:
space:
mode:
Diffstat (limited to 'packages/tasks')
-rw-r--r--packages/tasks/task-python-efl-examples.bb3
-rw-r--r--packages/tasks/task-python-efl.bb4
-rw-r--r--packages/tasks/task-python-everything.bb9
-rw-r--r--packages/tasks/task-slugos-toolchain-host.bb10
4 files changed, 20 insertions, 6 deletions
diff --git a/packages/tasks/task-python-efl-examples.bb b/packages/tasks/task-python-efl-examples.bb
index e78a4cabae..34efbeab6b 100644
--- a/packages/tasks/task-python-efl-examples.bb
+++ b/packages/tasks/task-python-efl-examples.bb
@@ -6,9 +6,10 @@ RDEPENDS = "\
python-ecore-examples \
python-emotion-examples \
python-edje-examples \
+ python-etk-examples \
python-epsilon-examples \
python-math python-textutils \
"
-PR = "ml3"
+PR = "ml4"
ALLOW_EMPTY = "1"
diff --git a/packages/tasks/task-python-efl.bb b/packages/tasks/task-python-efl.bb
index 1c7f23a1eb..d7b2d694dd 100644
--- a/packages/tasks/task-python-efl.bb
+++ b/packages/tasks/task-python-efl.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Python Bindings to the Enlightenment Foundation Libraries"
LICENSE = "MIT"
SECTION = "devel/python"
-RDEPENDS = "python-evas python-ecore python-emotion python-edje python-epsilon python-edbus"
-PR = "ml2"
+RDEPENDS = "python-evas python-ecore python-emotion python-edje python-etk python-epsilon python-edbus"
+PR = "ml3"
ALLOW_EMPTY = "1"
diff --git a/packages/tasks/task-python-everything.bb b/packages/tasks/task-python-everything.bb
index de6e5dfaf2..669c94159b 100644
--- a/packages/tasks/task-python-everything.bb
+++ b/packages/tasks/task-python-everything.bb
@@ -1,7 +1,7 @@
DESCRIPTION= "Everything Python"
HOMEPAGE = "http://www.vanille.de/projects/python.spy"
LICENSE = "MIT"
-PR = "ml27"
+PR = "ml30"
RDEPENDS = "\
python-ao \
@@ -9,10 +9,8 @@ RDEPENDS = "\
python-constraint \
python-dbus \
python-dialog \
- python-pydirectfb \
task-python-efl \
task-python-efl-examples \
- python-pycurl \
python-fam \
python-fnorb \
python-formencode \
@@ -39,10 +37,14 @@ RDEPENDS = "\
python-numeric \
python-ogg \
python-pexpect \
+ python-pyalsa \
+ python-pyalsaaudio \
python-pybluez \
python-pycairo \
python-pychecker \
python-pycodes \
+ python-pycurl \
+ python-pydirectfb \
python-pyephem \
python-pyfits \
python-pyflakes \
@@ -67,6 +69,7 @@ RDEPENDS = "\
python-pyweather \
python-pyxml \
python-pyxmlrpc \
+ python-pyyaml \
python-scapy \
python-scons \
python-setuptools \
diff --git a/packages/tasks/task-slugos-toolchain-host.bb b/packages/tasks/task-slugos-toolchain-host.bb
new file mode 100644
index 0000000000..7550301bfd
--- /dev/null
+++ b/packages/tasks/task-slugos-toolchain-host.bb
@@ -0,0 +1,10 @@
+require task-sdk-host.bb
+PR = "r0"
+DESCRIPTION = "Packages for a standalone SlugOS external toolchain"
+ALLOW_EMPTY = "1"
+
+PACKAGES = "${PN}"
+
+RDEPENDS_${PN} += "\
+ devio-sdk \
+"