summaryrefslogtreecommitdiff
path: root/packages/tasks
diff options
context:
space:
mode:
Diffstat (limited to 'packages/tasks')
-rw-r--r--packages/tasks/task-proper-tools.bb11
-rw-r--r--packages/tasks/task-self-hosting.bb31
2 files changed, 39 insertions, 3 deletions
diff --git a/packages/tasks/task-proper-tools.bb b/packages/tasks/task-proper-tools.bb
index dccdd13bdf..f9d3f7bfc7 100644
--- a/packages/tasks/task-proper-tools.bb
+++ b/packages/tasks/task-proper-tools.bb
@@ -1,5 +1,5 @@
-DESCRIPTION = "Proper tools for busybox haters"
-PR = "r2"
+DESCRIPTION = "Full versions of tools provided by busybox"
+PR = "r4"
PACKAGE_ARCH = "all"
ALLOW_EMPTY_${PN} = "1"
@@ -12,6 +12,7 @@ RDEPENDS = "\
sed \
wget \
patch \
+ tar \
diffutils \
less \
vim \
@@ -20,4 +21,8 @@ RDEPENDS = "\
module-init-tools \
"
-
+#
+# binutils-symlinks provide ar in a way which conflict with busybox - #1465 for more info
+#
+# busybox tar does not understand '--no-same-owner' option which bitbake use
+#
diff --git a/packages/tasks/task-self-hosting.bb b/packages/tasks/task-self-hosting.bb
new file mode 100644
index 0000000000..566e0956a0
--- /dev/null
+++ b/packages/tasks/task-self-hosting.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "All tools needed for OpenEmbedded build"
+SECTION = "devel"
+LICENSE = "MIT"
+RDEPENDS = "cpp gcc-symlinks binutils-symlinks \
+ perl perl-modules bitbake bash \
+ task-proper-tools glibc-utils \
+ linux-libc-headers-dev glibc-dev \
+ texinfo make cvs subversion monotone-6"
+
+#
+# quilt-native REQ bash and perl/perl-modules
+# binutils REQ texinfo
+#
+# bitbake will fetch all needed python modules
+#
+# toolchain:
+# - gcc-symlinks will fetch gcc
+# - binutils-symlinks will fetch binutils
+# - glibc-utils REQ cpp
+#
+# problems:
+# - binutils-symlinks conflict with busybox
+# - glibc-dev conflict with libc-linux-headers-dev
+# - perl is so granulated that it is probably impossible
+# to find out which packages are needed
+#
+
+ALLOW_EMPTY = "1"
+
+PACKAGES = "${PN}"
+PACKAGE_ARCH = "all"