summaryrefslogtreecommitdiff
path: root/packages/sylpheed
diff options
context:
space:
mode:
Diffstat (limited to 'packages/sylpheed')
-rw-r--r--packages/sylpheed/sylpheed-claws-extra-plugins.inc14
-rw-r--r--packages/sylpheed/sylpheed-claws-plugin-gtkhtml2-viewer-0.10_2.2.0.bb6
-rw-r--r--packages/sylpheed/sylpheed-claws-plugin-maildir-0.22_2.2.0.bb6
-rw-r--r--packages/sylpheed/sylpheed-claws-plugin-rssyl-0.4cvs8_2.2.0.bb6
-rw-r--r--packages/sylpheed/sylpheed-claws_2.2.0.bb35
5 files changed, 67 insertions, 0 deletions
diff --git a/packages/sylpheed/sylpheed-claws-extra-plugins.inc b/packages/sylpheed/sylpheed-claws-extra-plugins.inc
new file mode 100644
index 0000000000..e3b7a9e388
--- /dev/null
+++ b/packages/sylpheed/sylpheed-claws-extra-plugins.inc
@@ -0,0 +1,14 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent plugins"
+DEPENDS = "sylpheed-claws"
+MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sylpheed-claws/sylpheed-claws-extra-plugins-${PV}.tar.bz2"
+
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${libdir}/sylpheed-claws/plugins/*.so"
+
diff --git a/packages/sylpheed/sylpheed-claws-plugin-gtkhtml2-viewer-0.10_2.2.0.bb b/packages/sylpheed/sylpheed-claws-plugin-gtkhtml2-viewer-0.10_2.2.0.bb
new file mode 100644
index 0000000000..bc21b36a01
--- /dev/null
+++ b/packages/sylpheed/sylpheed-claws-plugin-gtkhtml2-viewer-0.10_2.2.0.bb
@@ -0,0 +1,6 @@
+include sylpheed-claws-extra-plugins.inc
+
+DEPENDS_append = " gtkhtml2"
+
+S = ${WORKDIR}/sylpheed-claws-extra-plugins-${PV}/gtkhtml2_viewer-0.10
+
diff --git a/packages/sylpheed/sylpheed-claws-plugin-maildir-0.22_2.2.0.bb b/packages/sylpheed/sylpheed-claws-plugin-maildir-0.22_2.2.0.bb
new file mode 100644
index 0000000000..56f86e6923
--- /dev/null
+++ b/packages/sylpheed/sylpheed-claws-plugin-maildir-0.22_2.2.0.bb
@@ -0,0 +1,6 @@
+include sylpheed-claws-extra-plugins.inc
+
+DEPENDS_append = " db"
+
+S = ${WORKDIR}/sylpheed-claws-extra-plugins-${PV}/maildir-0.22
+
diff --git a/packages/sylpheed/sylpheed-claws-plugin-rssyl-0.4cvs8_2.2.0.bb b/packages/sylpheed/sylpheed-claws-plugin-rssyl-0.4cvs8_2.2.0.bb
new file mode 100644
index 0000000000..3c95ee1b17
--- /dev/null
+++ b/packages/sylpheed/sylpheed-claws-plugin-rssyl-0.4cvs8_2.2.0.bb
@@ -0,0 +1,6 @@
+include sylpheed-claws-extra-plugins.inc
+
+DEPENDS_append = " libxml2 curl glib-2.0 gtk+"
+
+S = ${WORKDIR}/sylpheed-claws-extra-plugins-${PV}/rssyl-0.4cvs8
+
diff --git a/packages/sylpheed/sylpheed-claws_2.2.0.bb b/packages/sylpheed/sylpheed-claws_2.2.0.bb
new file mode 100644
index 0000000000..0308e60964
--- /dev/null
+++ b/packages/sylpheed/sylpheed-claws_2.2.0.bb
@@ -0,0 +1,35 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme libetpan libgnomeprint aspell"
+MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sylpheed-claws/sylpheed-claws-${PV}.tar.bz2"
+
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+
+EXTRA_OECONF = "--disable-aspell --disable-openssl --disable-aspell-test \
+ --disable-dillo-viewer-plugin --with-aspell-prefix=${STAGING_DIR}/${HOST_SYS} \
+ --enable-aspell"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed-claws.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed-claws.png ${D}${datadir}/pixmaps/
+}
+
+do_stage () {
+ autotools_stage_all
+}
+