summaryrefslogtreecommitdiff
path: root/packages/sylpheed/claws-mail_3.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/sylpheed/claws-mail_3.0.2.bb')
-rw-r--r--packages/sylpheed/claws-mail_3.0.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/sylpheed/claws-mail_3.0.2.bb b/packages/sylpheed/claws-mail_3.0.2.bb
new file mode 100644
index 0000000000..29e7a5bc63
--- /dev/null
+++ b/packages/sylpheed/claws-mail_3.0.2.bb
@@ -0,0 +1,43 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ libetpan openssl aspell"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/sylpheed-claws/claws-mail-${PV}.tar.bz2 \
+ file://desktop.patch;patch=1 \
+ "
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+
+EXTRA_OECONF = "--disable-aspell-test \
+ --enable--aspell \
+ --disable-manual \
+ --disable-crash-dialog \
+ --disable-jpilot \
+ --disable-trayicon-plugin \
+ --disable-spamassassin-plugin \
+ --disable-bogofilter-plugin \
+ --disable-pgpcore-plugin \
+ --disable-pgpmime-plugin \
+ --disable-pgpinline-plugin \
+ --disable-dillo-viewer-plugin \
+ --disable-clamav-plugin \
+ --disable-gnomeprint \
+ --disable-valgrind \
+ "
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 claws-mail.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 claws-mail.png ${D}${datadir}/pixmaps/
+}
+
+do_stage () {
+ autotools_stage_all
+}
+