summaryrefslogtreecommitdiff
path: root/packages/stunnel
diff options
context:
space:
mode:
Diffstat (limited to 'packages/stunnel')
-rw-r--r--packages/stunnel/files/init0
-rw-r--r--packages/stunnel/files/stunnel.conf0
-rw-r--r--packages/stunnel/stunnel_4.05.bb29
3 files changed, 29 insertions, 0 deletions
diff --git a/packages/stunnel/files/init b/packages/stunnel/files/init
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/stunnel/files/init
diff --git a/packages/stunnel/files/stunnel.conf b/packages/stunnel/files/stunnel.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/stunnel/files/stunnel.conf
diff --git a/packages/stunnel/stunnel_4.05.bb b/packages/stunnel/stunnel_4.05.bb
index e69de29bb2..3dc74e40dd 100644
--- a/packages/stunnel/stunnel_4.05.bb
+++ b/packages/stunnel/stunnel_4.05.bb
@@ -0,0 +1,29 @@
+SECTION = "console/network"
+DEPENDS = "openssl"
+HOMEPAGE = "http://www.stunnel.org"
+LICENSE = "GPL"
+DESCRIPTION = "Stunnel is a program that allows you to encrypt \
+arbitrary TCP connections inside SSL"
+PR = "r1"
+
+SRC_URI = "http://www.stunnel.org/download/stunnel/src/stunnel-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://automake.patch;patch=1 \
+ file://init \
+ file://stunnel.conf"
+
+S = "${WORKDIR}/stunnel-${PV}"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "stunnel"
+INITSCRIPT_PARAMS = "defaults"
+
+EXTRA_OECONF = "--with-ssl=${STAGING_LIBDIR}/.."
+
+do_install() {
+ autotools_do_install
+ install -d ${D}/${sysconfdir}/stunnel ${D}/${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/stunnel
+ install -m 644 ${WORKDIR}/stunnel.conf ${D}/${sysconfdir}/stunnel
+}