summaryrefslogtreecommitdiff
path: root/packages/squashfs-tools/squashfs-tools_2.0r2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/squashfs-tools/squashfs-tools_2.0r2.bb')
-rw-r--r--packages/squashfs-tools/squashfs-tools_2.0r2.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/packages/squashfs-tools/squashfs-tools_2.0r2.bb b/packages/squashfs-tools/squashfs-tools_2.0r2.bb
index 601724a5cb..f99cdb798e 100644
--- a/packages/squashfs-tools/squashfs-tools_2.0r2.bb
+++ b/packages/squashfs-tools/squashfs-tools_2.0r2.bb
@@ -4,12 +4,19 @@ MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
LICENSE = "GPLv2"
SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tar.gz \
- file://flags.patch;patch=1"
+ file://flags.patch;patch=1 \
+ file://squashfs2.0-tools-lzma.patch;patch=1"
S = "${WORKDIR}/squashfs${PV}/squashfs-tools"
prefix = ""
+do_compile() {
+ oe_runmake
+ oe_runmake mksquashfs-lzma
+}
+
do_install () {
install -d ${D}${sbindir}
install -m 0755 mksquashfs ${D}${sbindir}/
+ install -m 0755 mksquashfs-lzma ${D}${sbindir}/
}