summaryrefslogtreecommitdiff
path: root/packages/sqlite/sqlite-2.8.9/crosscompile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/sqlite/sqlite-2.8.9/crosscompile.patch')
-rw-r--r--packages/sqlite/sqlite-2.8.9/crosscompile.patch147
1 files changed, 0 insertions, 147 deletions
diff --git a/packages/sqlite/sqlite-2.8.9/crosscompile.patch b/packages/sqlite/sqlite-2.8.9/crosscompile.patch
deleted file mode 100644
index 8c334a78e8..0000000000
--- a/packages/sqlite/sqlite-2.8.9/crosscompile.patch
+++ /dev/null
@@ -1,147 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- sqlite/configure.ac~crosscompile 2003-12-22 15:29:33.000000000 +0100
-+++ sqlite/configure.ac 2004-01-14 01:03:08.000000000 +0100
-@@ -202,10 +202,10 @@
- default_build_cflags="-g"
- if test "$config_BUILD_CC" = ""; then
- AC_PROG_CC
-- if test "$cross_compiling" = "yes"; then
-- AC_MSG_ERROR([unable to find a compiler for building build tools])
-- fi
-- BUILD_CC=$CC
-+# if test "$cross_compiling" = "yes"; then
-+# AC_MSG_ERROR([unable to find a compiler for building build tools])
-+# fi
-+ BUILD_CC=gcc
- default_build_cflags=$CFLAGS
- else
- BUILD_CC=$config_BUILD_CC
-@@ -417,120 +417,14 @@
- fi
- AC_SUBST(TARGET_LIBS)
-
--##########
--# Figure out what C libraries are required to compile Tcl programs.
--#
--if test "$config_TARGET_TCL_LIBS" != ""; then
-- TARGET_TCL_LIBS="$config_TARGET_TCL_LIBS"
--else
-- if test "$with_tcl" != ""; then
-- extra=`echo $with_tcl/$tclsubdir/libtcl8*.a`
-- fi
-- CC=$TARGET_CC
-- AC_CHECK_FUNC(sin, LIBS="", LIBS="-lm")
-- AC_CHECK_LIB(dl, dlopen)
-- otherlibs=$LIBS
-- if test "$extra" != ""; then
-- LIBS=$extra
-- else
-- LIBS=""
-- AC_SEARCH_LIBS(Tcl_Init, dnl
-- tcl8.4 tcl8.3 tcl84 tcl83 tcl,,,$otherlibs)
-- fi
-- TARGET_TCL_LIBS="$LIBS $otherlibs"
--fi
--AC_SUBST(TARGET_TCL_LIBS)
--
--##########
--# Figure out where to get the TCL header files.
--#
--AC_MSG_CHECKING([TCL header files])
--found=no
--if test "$config_TARGET_TCL_INC" != ""; then
-- TARGET_TCL_INC=$config_TARGET_TCL_INC
-- found=yes
--else
-- if test "$with_tcl" != ""; then
-- TARGET_TCL_INC="-I$with_tcl/generic -I$with_tcl/$tclsubdir"
-- found=yes
-- else
-- TARGET_TCL_INC=""
-- found=no
-- fi
--fi
--if test "$found" = "yes"; then
-- AC_MSG_RESULT($TARGET_TCL_INC)
--else
-- AC_MSG_RESULT(not specified: still searching...)
-- AC_CHECK_HEADER(tcl.h, [found=yes])
--fi
--if test "$found" = "no"; then
-- for dir in /usr/local /usr/X11 /usr/X11R6 /usr/pkg /usr/contrib /usr; do
-- AC_CHECK_FILE($dir/include/tcl.h, found=yes)
-- if test "$found" = "yes"; then
-- TARGET_TCL_INC="-I$dir/include"
-- break
-- fi
-- done
--fi
--if test "$found" = "no"; then
-- TARGET_TCL_INC="-DNO_TCL=1"
--fi
-+TARGET_TCL_INC="-DNO_TCL=1"
- AC_SUBST(TARGET_TCL_INC)
-
--##########
--# Figure out what C libraries are required to compile programs
--# that use "readline()" library.
--#
--if test "$config_TARGET_READLINE_LIBS" != ""; then
-- TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS"
--else
-- CC=$TARGET_CC
-- LIBS=""
-- AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap])
-- AC_CHECK_LIB([readline], [readline])
-- TARGET_READLINE_LIBS="$LIBS"
--fi
-+TARGET_READLINE_LIBS="-lreadline"
- AC_SUBST(TARGET_READLINE_LIBS)
-
--##########
--# Figure out where to get the READLINE header files.
--#
--AC_MSG_CHECKING([readline header files])
--found=no
--if test "$config_TARGET_READLINE_INC" != ""; then
-- TARGET_READLINE_INC=$config_TARGET_READLINE_INC
-- found=yes
--fi
--if test "$found" = "yes"; then
-- AC_MSG_RESULT($TARGET_READLINE_INC)
--else
-- AC_MSG_RESULT(not specified: still searching...)
-- AC_CHECK_HEADER(readline.h, [found=yes])
--fi
--if test "$found" = "no"; then
-- for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do
-- AC_CHECK_FILE($dir/include/readline.h, found=yes)
-- if test "$found" = "yes"; then
-- TARGET_READLINE_INC="-I$dir/include"
-- break
-- fi
-- AC_CHECK_FILE($dir/include/readline/readline.h, found=yes)
-- if test "$found" = "yes"; then
-- TARGET_READLINE_INC="-I$dir/include/readline"
-- break
-- fi
-- done
--fi
--if test "$found" = "yes"; then
-- if test "$TARGET_READLINE_LIBS" = ""; then
-- TARGET_HAVE_READLINE=0
-- else
-- TARGET_HAVE_READLINE=1
-- fi
--else
-- TARGET_HAVE_READLINE=0
--fi
-+TARGET_HAVE_READLINE=1
-+TARGET_READLINE_INC=""
- AC_SUBST(TARGET_READLINE_INC)
- AC_SUBST(TARGET_HAVE_READLINE)
-