summaryrefslogtreecommitdiff
path: root/packages/speech-dispatcher
diff options
context:
space:
mode:
Diffstat (limited to 'packages/speech-dispatcher')
-rw-r--r--packages/speech-dispatcher/files/confSpeechd.conf_00.patch26
-rw-r--r--packages/speech-dispatcher/speech-dispatcher_0.6.5.bb16
2 files changed, 37 insertions, 5 deletions
diff --git a/packages/speech-dispatcher/files/confSpeechd.conf_00.patch b/packages/speech-dispatcher/files/confSpeechd.conf_00.patch
new file mode 100644
index 0000000000..de1a776e3b
--- /dev/null
+++ b/packages/speech-dispatcher/files/confSpeechd.conf_00.patch
@@ -0,0 +1,26 @@
+--- speech-dispatcher-0.6.5/config/speechd.conf.in.orig 2008-01-04 13:45:43.000000000 +0000
++++ speech-dispatcher-0.6.5/config/speechd.conf.in 2008-01-04 13:47:31.000000000 +0000
+@@ -129,10 +129,10 @@
+ # - configuration is the path to the config file of this module,
+ # either relative (to etc/speechd/modules/) or absolute
+
+-AddModule "espeak" "sd_espeak" "espeak.conf"
+-AddModule "festival" "sd_festival" "festival.conf"
+-AddModule "flite" "sd_flite" "flite.conf"
+-#AddModule "espeak-generic" "sd_generic" "espeak-generic.conf"
++#AddModule "espeak" "sd_espeak" "espeak.conf"
++#AddModule "festival" "sd_festival" "festival.conf"
++#AddModule "flite" "sd_flite" "flite.conf"
++AddModule "espeak-generic" "sd_generic" "espeak-generic.conf"
+ #AddModule "epos-generic" "sd_generic" "epos-generic.conf"
+ #AddModule "dtk-generic" "sd_generic" "dtk-generic.conf"
+ #AddModule "ibmtts" "sd_ibmtts" "ibmtts.conf"
+@@ -172,6 +172,6 @@
+
+ # There are some sample client settings
+
+-Include "clients/emacs.conf"
+-Include "clients/gnome-speech.conf"
++#Include "clients/emacs.conf"
++#Include "clients/gnome-speech.conf"
+
diff --git a/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb b/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
index ac001bf1b7..68bfd8a347 100644
--- a/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
+++ b/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
@@ -5,12 +5,13 @@ LICENSE = "GPLv2"
DEPENDS = "flite libdotconf glib-2.0"
RPROVIDES += "speechd"
-PR = "r0"
+PR = "r1"
inherit autotools
SRC_URI = "http://www.freebsoft.org/pub/projects/speechd/${PN}-${PV}.tar.gz \
- file://srcMakefile.am.patch;patch=1 "
+ file://srcMakefile.am.patch;patch=1 \
+ file://confSpeechd.conf_00.patch;patch=1"
LEAD_SONAME = "libspeechd.so"
@@ -18,15 +19,20 @@ do_install() {
install -d ${D}${bindir}
install -d ${D}${includedir}
install -d ${D}${libdir}/${PN}-modules
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/modules
oe_libinstall -so -C src/audio libsdaudio ${D}${libdir}
oe_libinstall -so -C src/c/api libspeechd ${D}${libdir}
install -m 0644 ${S}/src/c/api/libspeechd.h ${D}${includedir}
- install -m 0755 ${S}/src/c/clients/say/spd-say ${D}${bindir}
+ install -m 0755 ${S}/src/c/clients/say/.libs/spd-say ${D}${bindir}
install -m 0755 ${S}/src/c/clients/spdsend/spdsend ${D}${bindir}
- install -m 0755 ${S}/src/server/speech-dispatcher ${D}${bindir}
- install -m 0755 ${S}/src/modules/sd_* ${D}${libdir}/${PN}-modules/
+ install -m 0755 ${S}/src/server/.libs/speech-dispatcher ${D}${bindir}
+ install -m 0755 ${S}/src/modules/.libs/sd_* ${D}${libdir}/${PN}-modules/
+
+ install -m 0644 ${S}/config/speechd.conf ${D}${sysconfdir}
+ install -m 0644 ${S}/config/modules/*.conf ${D}${sysconfdir}/modules
}
do_stage() {