summaryrefslogtreecommitdiff
path: root/packages/samba/samba_3.0.23c.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/samba/samba_3.0.23c.bb')
-rw-r--r--packages/samba/samba_3.0.23c.bb53
1 files changed, 13 insertions, 40 deletions
diff --git a/packages/samba/samba_3.0.23c.bb b/packages/samba/samba_3.0.23c.bb
index 96343aa6a4..3a2cfd30aa 100644
--- a/packages/samba/samba_3.0.23c.bb
+++ b/packages/samba/samba_3.0.23c.bb
@@ -1,48 +1,21 @@
require samba.inc
-inherit update-rc.d
-PR = "r3"
+PR = "r4"
-SRC_URI += "file://config-lfs.patch;patch=1 \
- file://init \
- file://quota.patch;patch=1;pnum=0 \
- file://cifs.patch;patch=1 \
- "
+SRC_URI += "file://cifs.patch;patch=1 \
+ "
-INITSCRIPT_NAME = "samba"
-# No dependencies, goes in at level 20 (NOTE: take care with the
-# level, later levels put the shutdown later too - see the links
-# in rc6.d, the shutdown must precede network shutdown).
-INITSCRIPT_PARAMS = "defaults"
-CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf"
-
-# The file system settings --foodir=dirfoo and overridden unconditionally
-# in the samba config by --with-foodir=dirfoo - even if the --with is not
-# specified! Fix that here. Set the privatedir to /etc/samba/private.
EXTRA_OECONF += "\
- samba_cv_struct_timespec=yes \
- --with-configdir=${sysconfdir}/samba \
- --with-privatedir=${sysconfdir}/samba/private \
- --with-lockdir=${localstatedir}/lock \
- --with-piddir=${localstatedir}/run \
- --with-logfilebase=${localstatedir}/log \
- --with-libdir=${libdir} \
- --with-mandir=${mandir} \
- --with-swatdir=${datadir}/swat \
- "
+ --without-ads \
+ "
-do_install_append() {
- install -d "${D}${localstatedir}/log"
- install -d "${D}${sysconfdir}/init.d"
- install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/samba
- install -d "${D}${sysconfdir}/samba"
- install -c -m 644 ../examples/smb.conf.default ${D}${sysconfdir}/samba/smb.conf
+do_compile () {
+ oe_runmake proto_exists
+ base_do_compile
+ ${CC} client/mount.cifs.c -o mount.cifs
}
-PACKAGES =+ "swat"
-
-FILES_swat = "${sbindir}/swat ${datadir}/swat ${libdir}/*.msg"
-FILES_${PN} += "${libdir}/vfs/*.so ${libdir}/charset/*.so ${libdir}/*.dat ${libdir}/auth/*.so"
-#
-# bug fix for samba.inc:
-FILES_cifs-doc += "${mandir}/man8/mount.cifs.8"
+do_stage() {
+ install -m 0644 include/libsmbclient.h ${STAGING_INCDIR}
+ oe_libinstall -C bin -a -so libsmbclient ${STAGING_LIBDIR}
+}