summaryrefslogtreecommitdiff
path: root/packages/rpm
diff options
context:
space:
mode:
Diffstat (limited to 'packages/rpm')
-rw-r--r--packages/rpm/files/cross_libpaths.patch0
-rw-r--r--packages/rpm/files/fix_mypath.patch0
-rw-r--r--packages/rpm/rpm_4.4.bb45
3 files changed, 45 insertions, 0 deletions
diff --git a/packages/rpm/files/cross_libpaths.patch b/packages/rpm/files/cross_libpaths.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/rpm/files/cross_libpaths.patch
diff --git a/packages/rpm/files/fix_mypath.patch b/packages/rpm/files/fix_mypath.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/rpm/files/fix_mypath.patch
diff --git a/packages/rpm/rpm_4.4.bb b/packages/rpm/rpm_4.4.bb
index e69de29bb2..aebdf29d2a 100644
--- a/packages/rpm/rpm_4.4.bb
+++ b/packages/rpm/rpm_4.4.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "The RPM Package Manager."
+HOMEPAGE = "http://rpm.org/"
+LICENSE = "LGPL GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+# NOTE: currently rpm doesn't support using an external popt,
+# file, or db3. FIXME: patch it to support that.
+# DEPENDS = "db3 popt file zlib"
+DEPENDS = "zlib"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.jbj.org/pub/rpm-4.4.x/rpm-4.4-1.src.rpm \
+ file://fix_mypath.patch;patch=1 \
+ file://cross_libpaths.patch;patch=1"
+TARBALL = "${WORKDIR}/rpm-4.4.tar.gz"
+
+inherit autotools gettext
+
+acpaths = ""
+# NOTE: currently BROKEN because its internal build of 'file' tries
+# to run the binary it builds. Either switch to an external build,
+# or depend on our file-native and make it call that.
+BROKEN = "1"
+EXTRA_OECONF = "--without-python \
+ --without-apidocs \
+ --without-selinux \
+ --without-lua \
+ --without-dmalloc \
+ --without-efence"
+
+python unpack_again () {
+ import bb, os
+ os.chdir(bb.data.getVar('WORKDIR', d, 1) or '')
+ if not oe_unpack_file(bb.data.expand('${TARBALL}', d), d):
+ raise bb.build.FuncFailed(bb.data.expand("Unable to unpack ${TARBALL}", d))
+}
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ bb.build.exec_func('unpack_again', d)
+}
+
+do_configure () {
+ touch db3/configure.ac
+ autotools_do_configure
+}