summaryrefslogtreecommitdiff
path: root/packages/rp-pppoe/rp-pppoe_3.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/rp-pppoe/rp-pppoe_3.8.bb')
-rw-r--r--packages/rp-pppoe/rp-pppoe_3.8.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/packages/rp-pppoe/rp-pppoe_3.8.bb b/packages/rp-pppoe/rp-pppoe_3.8.bb
index c4d5ff88d2..ae3e52bfce 100644
--- a/packages/rp-pppoe/rp-pppoe_3.8.bb
+++ b/packages/rp-pppoe/rp-pppoe_3.8.bb
@@ -3,7 +3,8 @@ HOMEPAGE = "http://www.roaringpenguin.com/en/penguin/openSourceProducts/rpPppoe"
SECTION = "console/network"
LICENSE = "GPLv2"
RDEPENDS = "ppp"
-PR = "r0"
+RRECOMMENDS = "ppp-oe"
+PR = "r1"
SRC_URI = "http://www.roaringpenguin.com/files/download/${P}.tar.gz \
file://configure_in_cross.patch;patch=1;pnum=2 \
@@ -15,8 +16,11 @@ inherit autotools
do_install() {
# Set timeout to 0. Fixes lots of reconnect issues
+ # No need for full path to the PPPoE plugin, and it's in a different
# Can't patch this in because it's outside of what we have {S} set to.
- sed -i -e 's,\(CONNECT_TIMEOUT=\)30,\10,g' ${S}/../configs/pppoe.conf
+ sed -i -e 's,\(CONNECT_TIMEOUT=\)30,\10,g' \
+ -e 's,\(LINUX_PLUGIN=\)/etc/ppp/plugins/rp-pppoe.so,\1rp-pppoe.so,g' \
+ ${S}/../configs/pppoe.conf
# Install
oe_runmake -C ${S} RPM_INSTALL_ROOT=${D} docdir=${docdir} install
}
@@ -27,3 +31,8 @@ pkg_postinst() {
fi
chmod 4755 ${sbindir}/pppoe
}
+
+CONFFILES_${PN} = "${sysconfdir}/ppp/pppoe-server-options \
+ ${sysconfdir}/ppp/pppoe.conf \
+ ${sysconfdir}/ppp/firewall-standalone \
+ ${sysconfdir}/ppp/firewall-masq"