summaryrefslogtreecommitdiff
path: root/packages/quake
diff options
context:
space:
mode:
Diffstat (limited to 'packages/quake')
-rw-r--r--packages/quake/quake2_svn.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/packages/quake/quake2_svn.bb b/packages/quake/quake2_svn.bb
index a90b3183bc..5ce56dc93b 100644
--- a/packages/quake/quake2_svn.bb
+++ b/packages/quake/quake2_svn.bb
@@ -26,7 +26,7 @@ do_install() {
install -d ${D}/${bindir}
echo -e "#!/bin/sh \ncd ${libdir}/quake2 && ./quake2 \$@ \n" > ${D}/${bindir}/quake2
- ( cd ${S}/debug${TARGET_ARCH} ; ln -sf gamei386.so game${TARGET_ARCH}.so )
+ ( cd ${S}/debug${TARGET_ARCH} ; ln -sf game$(uname -m | sed -e s/i.86/i386/ -e s/sun4u/sparc/ -e s/sparc64/sparc/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/alpha/axp/).so game${TARGET_ARCH}.so )
install -d ${D}/${libdir}/quake2/baseq2/ctf
install -m 0755 ${S}/debug${TARGET_ARCH}/game${TARGET_ARCH}.so ${D}/${libdir}/quake2/baseq2
install -m 0755 ${S}/debug${TARGET_ARCH}/ref*.so ${D}/${libdir}/quake2