summaryrefslogtreecommitdiff
path: root/packages/qpe-gaim/qpe-libgaim_20041030.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/qpe-gaim/qpe-libgaim_20041030.bb')
-rw-r--r--packages/qpe-gaim/qpe-libgaim_20041030.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/qpe-gaim/qpe-libgaim_20041030.bb b/packages/qpe-gaim/qpe-libgaim_20041030.bb
index e69de29bb2..c9a168fb79 100644
--- a/packages/qpe-gaim/qpe-libgaim_20041030.bb
+++ b/packages/qpe-gaim/qpe-libgaim_20041030.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "A multi protocol instant messager library, Qt/Embedded based Palmtop Environments Edition"
+SECTION = "opie/applications"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "openssl glib-2.0"
+RDEPENDS = "libgaim-plugins"
+LICENSE = "GPL"
+HOMEPAGE = "http://qpe-gaim.sourceforge.net/"
+PV = "0.4+cvs-20041030"
+PR = "r3"
+
+SRC_URI = "http://www.vanille.de/mirror/qpe-gaim_20041030.tar.bz2 \
+ file://fix-compilation.patch;patch=1 \
+ file://dont-look-for-gtk.patch;patch=1"
+S = "${WORKDIR}/libgaim"
+
+inherit autotools
+
+EXTRA_OE_CONF = "--disable-audio --disable-gtkspell --disable-perl \
+ --with-dynamic-prpls=gg,irc,jabber,msn,napster,oscar,yahoo \
+ --disable-screensaver --disable-sm --disable-glibtest \
+ --disable-gtktest --disable-startup-notification \
+ --disable-gevolution --disable-aotest --disable-audiofiletest"
+
+CFLAGS_append = " -I${STAGING_INCDIR}/glib-2.0"
+
+do_configure_prepend() {
+ ln -s src libgaim
+ touch intl/Makefile.in
+ touch po/Makefile.in.in
+ install -d build-root
+ touch build-root/mkipk.sh.in.in
+}
+
+do_stage() {
+ oe_libinstall -so -C src libgaim ${QTDIR}/lib
+}
+
+#FIXME: use do_packages to create individual packages for each of the plugins
+python populate_packages_prepend () {
+ plugindir = bb.data.expand('${libdir}/gaim', d)
+ do_split_packages(d, plugindir, '^lib(.*)\.so$', 'libgaim-protocol-%s', 'GAIM plugin for %s protocol', extra_depends='' )
+}
+
+PACKAGES += "libgaim-plugins"
+FILES_libgaim-plugins = "${libdir}/gaim/autorecon.so ${libdir}/gaim/s*.so"
+