summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-dbus_0.81.1.bb6
-rw-r--r--packages/python/python-edbus_cvs.bb3
-rw-r--r--packages/python/python-efl.bb4
3 files changed, 8 insertions, 5 deletions
diff --git a/packages/python/python-dbus_0.81.1.bb b/packages/python/python-dbus_0.81.1.bb
index ad3b1c177b..86628bad26 100644
--- a/packages/python/python-dbus_0.81.1.bb
+++ b/packages/python/python-dbus_0.81.1.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl python-pyrex-native python"
RDEPENDS = "dbus python-threading python-io python-stringold python-logging"
-PR = "ml1"
+PR = "ml2"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
file://allow-older-autotools.patch;patch=1 \
@@ -16,3 +16,7 @@ inherit distutils-base autotools
EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/packages/python/python-edbus_cvs.bb b/packages/python/python-edbus_cvs.bb
index 7a4d53762f..652cf919cd 100644
--- a/packages/python/python-edbus_cvs.bb
+++ b/packages/python/python-edbus_cvs.bb
@@ -1,8 +1,7 @@
require python-efl.inc
-# broken until someone adds dbus 1.1.x
DEPENDS += "edbus dbus-1.1"
-PR = "r0"
+PR = "r1"
SRC_URI = "${E_CVS};module=e17/proto/python-efl/python-e_dbus"
S = "${WORKDIR}/python-e_dbus"
diff --git a/packages/python/python-efl.bb b/packages/python/python-efl.bb
index ec5e9cd7e2..1c7f23a1eb 100644
--- a/packages/python/python-efl.bb
+++ b/packages/python/python-efl.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Python Bindings to the Enlightenment Foundation Libraries"
LICENSE = "MIT"
SECTION = "devel/python"
-RDEPENDS = "python-evas python-ecore python-emotion python-edje python-epsilon"
-PR = "ml1"
+RDEPENDS = "python-evas python-ecore python-emotion python-edje python-epsilon python-edbus"
+PR = "ml2"
ALLOW_EMPTY = "1"