summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-2.5-manifest.inc5
-rw-r--r--packages/python/python-edje/.mtn2git_empty0
-rw-r--r--packages/python/python-edje/0001-fix-unicode-conversion.patch41
-rw-r--r--packages/python/python-edje_cvs.bb6
-rw-r--r--packages/python/python-ptrace_0.3.2.bb10
-rw-r--r--packages/python/python-pycurl/.mtn2git_empty0
-rw-r--r--packages/python/python-pycurl/no-static-link.patch14
-rw-r--r--packages/python/python-pycurl_7.18.2.bb (renamed from packages/python/python-pycurl_7.16.4.bb)13
-rw-r--r--packages/python/python_2.5.2.bb6
9 files changed, 87 insertions, 8 deletions
diff --git a/packages/python/python-2.5-manifest.inc b/packages/python/python-2.5-manifest.inc
index a0ec692095..9ae307e7a4 100644
--- a/packages/python/python-2.5-manifest.inc
+++ b/packages/python/python-2.5-manifest.inc
@@ -1,6 +1,7 @@
# WARNING: This file is AUTO GENERATED: Manual edits will be lost next time I regenerate the file.
# Generator: './generate-manifest-2.5.py' Version 20080722 (C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
# Visit the Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
+
PROVIDES+="python-profile python-threading python-distutils python-doctest python-codecs python-ctypes python-pickle python-datetime python-core python-io python-compiler python-compression python-re python-xmlrpc python-terminal python-email python-image python-tests python-core-dbg python-resource python-devel python-difflib python-math python-syslog python-hotshot python-unixadmin python-textutils python-tkinter python-gdbm python-fcntl python-netclient python-pprint python-netserver python-curses python-smtpd python-html python-readline python-subprocess python-pydoc python-logging python-mailbox python-xml python-mime python-sqlite3 python-sqlite3-tests python-unittest python-stringold python-robotparser python-lib-old-and-deprecated python-compile python-debugger python-shell python-bsddb python-mmap python-zlib python-db python-crypt python-idle python-lang python-audio "
@@ -268,9 +269,9 @@ RDEPENDS_python-shell="python-core python-re"
FILES_python-shell="${libdir}/python2.5/cmd.* ${libdir}/python2.5/commands.* ${libdir}/python2.5/dircache.* ${libdir}/python2.5/fnmatch.* ${libdir}/python2.5/glob.* ${libdir}/python2.5/popen2.* ${libdir}/python2.5/shutil.* "
DESCRIPTION_python-bsddb="Python Berkeley Database Bindings"
-PR_python-bsddb="ml0"
+PR_python-bsddb="ml1"
RDEPENDS_python-bsddb="python-core"
-FILES_python-bsddb="${libdir}/python2.5/bsddb "
+FILES_python-bsddb="${libdir}/python2.5/bsddb ${libdir}/python2.5/lib-dynload/_bsddb.so "
DESCRIPTION_python-mmap="Python Memory-Mapped-File Support"
PR_python-mmap="ml0"
diff --git a/packages/python/python-edje/.mtn2git_empty b/packages/python/python-edje/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-edje/.mtn2git_empty
diff --git a/packages/python/python-edje/0001-fix-unicode-conversion.patch b/packages/python/python-edje/0001-fix-unicode-conversion.patch
new file mode 100644
index 0000000000..7964e097d1
--- /dev/null
+++ b/packages/python/python-edje/0001-fix-unicode-conversion.patch
@@ -0,0 +1,41 @@
+From fa12a33b5a3c0e86231ca84967d9eff456e5f314 Mon Sep 17 00:00:00 2001
+From: Jan Luebbe <jluebbe@debian.org>
+Date: Sat, 9 Aug 2008 18:30:04 +0200
+Subject: [PATCH] fix unicode conversion
+
+---
+ edje/edje.c_edje_object.pxi | 11 +++++++----
+ 1 files changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/edje/edje.c_edje_object.pxi b/edje/edje.c_edje_object.pxi
+index 0f4da68..21c237e 100644
+--- a/edje/edje.c_edje_object.pxi
++++ b/edje/edje.c_edje_object.pxi
+@@ -391,17 +391,20 @@ cdef public class Edje(evas.c_evas.Object) [object PyEdje, type PyEdje_Type]:
+ else:
+ raise TypeError("func must be callable or None")
+
+- def part_text_set(self, char *part, char *text):
+- edje_object_part_text_set(self.obj, part, text)
++ def part_text_set(self, char *part, text):
++ cdef char *s
++ u = text.encode("utf8")
++ s = u
++ edje_object_part_text_set(self.obj, part, s)
+
+ def part_text_get(self, char *part):
+- "@rtype: str"
++ "@rtype: unicode"
+ cdef char *s
+ s = edje_object_part_text_get(self.obj, part)
+ if s == NULL:
+ return None
+ else:
+- return s
++ return s.decode("utf8")
+
+ def part_swallow(self, char *part, c_evas.Object obj):
+ """Swallows an object into the edje
+--
+1.5.6.3
+
diff --git a/packages/python/python-edje_cvs.bb b/packages/python/python-edje_cvs.bb
index 144fcfddde..a0665e8b09 100644
--- a/packages/python/python-edje_cvs.bb
+++ b/packages/python/python-edje_cvs.bb
@@ -1,5 +1,9 @@
require python-efl.inc
+
DEPENDS += "edje python-evas"
RDEPENDS += "python-evas"
+
+SRC_URI += "file://0001-fix-unicode-conversion.patch;patch=1"
+
PV = "0.2.1+cvs${SRCDATE}"
-PR = "r2"
+PR = "r3"
diff --git a/packages/python/python-ptrace_0.3.2.bb b/packages/python/python-ptrace_0.3.2.bb
new file mode 100644
index 0000000000..a039476c39
--- /dev/null
+++ b/packages/python/python-ptrace_0.3.2.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "python-ptrace is a debugger using ptrace."
+HOMEPAGE = "http://fusil.hachoir.org/trac/wiki/python-ptrace"
+SECTION = "devel/python"
+LICENSE = "GPLv2"
+PR = "ml0"
+
+SRC_URI = "http://pypi.python.org/packages/source/p/ptrace/ptrace-${PV}.tar.gz"
+S = "${WORKDIR}/ptrace-${PV}"
+
+inherit distutils
diff --git a/packages/python/python-pycurl/.mtn2git_empty b/packages/python/python-pycurl/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-pycurl/.mtn2git_empty
diff --git a/packages/python/python-pycurl/no-static-link.patch b/packages/python/python-pycurl/no-static-link.patch
new file mode 100644
index 0000000000..b7c5ab9c9c
--- /dev/null
+++ b/packages/python/python-pycurl/no-static-link.patch
@@ -0,0 +1,14 @@
+Index: pycurl-7.18.2/setup.py
+===================================================================
+--- pycurl-7.18.2.orig/setup.py
++++ pycurl-7.18.2/setup.py
+@@ -97,8 +97,7 @@ else:
+ else:
+ extra_compile_args.append(e)
+ libs = split_quoted(
+- os.popen("'%s' --libs" % CURL_CONFIG).read()+\
+- os.popen("'%s' --static-libs" % CURL_CONFIG).read())
++ os.popen("'%s' --libs" % CURL_CONFIG).read())
+ for e in libs:
+ if e[:2] == "-l":
+ libraries.append(e[2:])
diff --git a/packages/python/python-pycurl_7.16.4.bb b/packages/python/python-pycurl_7.18.2.bb
index a9480ad949..406add10c8 100644
--- a/packages/python/python-pycurl_7.16.4.bb
+++ b/packages/python/python-pycurl_7.18.2.bb
@@ -2,11 +2,20 @@ DESCRIPTION = "libcurl Python Bindings"
SECTION = "devel/python"
PRIORITY = "optional"
LICENSE = "LGPL"
-RDEPENDS = "python-core curl (>=${PV})"
DEPENDS = "curl-${PV}"
SRCNAME = "pycurl"
+PR = "ml0"
-SRC_URI = "http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz"
+SRC_URI = "\
+ http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz \
+ file://no-static-link.patch;patch=1 \
+"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
+
+do_install_append() {
+ mv -f ${D}${datadir}/share/* ${D}${datadir}/
+}
+
+RDEPENDS = "python-core curl (>=${PV})"
diff --git a/packages/python/python_2.5.2.bb b/packages/python/python_2.5.2.bb
index 707c0f562e..c68f7d5e3b 100644
--- a/packages/python/python_2.5.2.bb
+++ b/packages/python/python_2.5.2.bb
@@ -3,10 +3,10 @@ HOMEPAGE = "http://www.python.org"
LICENSE = "PSF"
SECTION = "devel/python"
PRIORITY = "optional"
-DEPENDS = "python-native readline zlib gdbm openssl sqlite3 tcl tk"
-DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
+DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl tk zlib"
+DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# bump this on every change in contrib/python/generate-manifest-2.5.py
-PR = "ml8"
+PR = "ml9"
PYTHON_MAJMIN = "2.5"