summaryrefslogtreecommitdiff
path: root/packages/python/python-setuptools_0.6c6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/python/python-setuptools_0.6c6.bb')
-rw-r--r--packages/python/python-setuptools_0.6c6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/python/python-setuptools_0.6c6.bb b/packages/python/python-setuptools_0.6c6.bb
new file mode 100644
index 0000000000..ef56b9b652
--- /dev/null
+++ b/packages/python/python-setuptools_0.6c6.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "MIT-like"
+RDEPENDS = "python-core python-zlib"
+SRCNAME = "setuptools"
+PR = "ml1"
+
+SRC_URI = "http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR_NATIVE}/python setup.py install
+}