summaryrefslogtreecommitdiff
path: root/packages/python/python-dbus_0.82.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/python/python-dbus_0.82.4.bb')
-rw-r--r--packages/python/python-dbus_0.82.4.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/python/python-dbus_0.82.4.bb b/packages/python/python-dbus_0.82.4.bb
new file mode 100644
index 0000000000..9f00c64701
--- /dev/null
+++ b/packages/python/python-dbus_0.82.4.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT"
+DEPENDS = "expat glib-2.0 virtual/libintl python-pyrex-native python"
+RDEPENDS = "dbus python-threading python-io python-stringold python-logging"
+PR = "ml0"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils-base autotools
+
+export BUILD_SYS := "${BUILD_SYS}"
+export HOST_SYS := "${HOST_SYS}"
+
+do_stage() {
+ autotools_stage_all
+}
+