summaryrefslogtreecommitdiff
path: root/packages/pulseaudio
diff options
context:
space:
mode:
Diffstat (limited to 'packages/pulseaudio')
-rw-r--r--packages/pulseaudio/files/asound.conf.pulseaudio7
-rw-r--r--packages/pulseaudio/padevchooser_0.9.3.bb9
-rw-r--r--packages/pulseaudio/pulseaudio-0.9.10/2113.diff19
-rw-r--r--packages/pulseaudio/pulseaudio-0.9.10/2114.diff15
-rw-r--r--packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch48
-rw-r--r--packages/pulseaudio/pulseaudio-alsa-wrapper.bb43
-rw-r--r--packages/pulseaudio/pulseaudio-esd-wrapper.bb42
-rw-r--r--packages/pulseaudio/pulseaudio-meta/.mtn2git_empty0
-rw-r--r--packages/pulseaudio/pulseaudio-meta/asound.conf8
-rwxr-xr-xpackages/pulseaudio/pulseaudio-meta/pulseaudio50
-rw-r--r--packages/pulseaudio/pulseaudio-meta/session36
-rw-r--r--packages/pulseaudio/pulseaudio-meta_0.9.10.bb44
-rw-r--r--packages/pulseaudio/pulseaudio.inc (renamed from packages/pulseaudio/pulse.inc)0
-rw-r--r--packages/pulseaudio/pulseaudio_0.9.10.bb16
-rw-r--r--packages/pulseaudio/pulseaudio_0.9.6.bb4
-rw-r--r--packages/pulseaudio/pulseaudio_0.9.9.bb4
16 files changed, 338 insertions, 7 deletions
diff --git a/packages/pulseaudio/files/asound.conf.pulseaudio b/packages/pulseaudio/files/asound.conf.pulseaudio
new file mode 100644
index 0000000000..71f01f2c3c
--- /dev/null
+++ b/packages/pulseaudio/files/asound.conf.pulseaudio
@@ -0,0 +1,7 @@
+pcm.pulse {
+ type pulse
+}
+
+ctl.pulse {
+ type pulse
+}
diff --git a/packages/pulseaudio/padevchooser_0.9.3.bb b/packages/pulseaudio/padevchooser_0.9.3.bb
new file mode 100644
index 0000000000..535e871242
--- /dev/null
+++ b/packages/pulseaudio/padevchooser_0.9.3.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "PulseAudio Device Chooser (padevchooser) is a simple GTK tool which registers an icon in the tray area and allows quick access to some features of the PulseAudio sound server"
+LICENSE = "GPLv2"
+DEPENDS = "gtk+ libnotify gconf pulseaudio"
+
+SRC_URI = "http://0pointer.de/lennart/projects/padevchooser/padevchooser-${PV}.tar.gz"
+
+inherit autotools
+
+
diff --git a/packages/pulseaudio/pulseaudio-0.9.10/2113.diff b/packages/pulseaudio/pulseaudio-0.9.10/2113.diff
new file mode 100644
index 0000000000..666ed34ad3
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-0.9.10/2113.diff
@@ -0,0 +1,19 @@
+from upstream svn r2113
+
+Index: configure.ac
+===================================================================
+--- configure.ac (wersja 2112)
++++ configure.ac (wersja 2113)
+@@ -172,6 +172,12 @@
+ AC_SUBST(LIBLTDL)
+ AC_CONFIG_SUBDIRS(libltdl)
+
++old_LIBS=$LIBS
++LIBS="$LIBS $LIBLTDL"
++AC_CHECK_FUNCS([lt_dlmutex_register])
++LIBS=$old_LIBS
++AC_CHECK_TYPES([lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
++
+ if test "x$enable_ltdl_install" = "xno" && test "x$ac_cv_lib_ltdl_lt_dlinit" = "xno" ; then
+ AC_MSG_ERROR([[
+
diff --git a/packages/pulseaudio/pulseaudio-0.9.10/2114.diff b/packages/pulseaudio/pulseaudio-0.9.10/2114.diff
new file mode 100644
index 0000000000..cbd82eeb84
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-0.9.10/2114.diff
@@ -0,0 +1,15 @@
+from upstream svn r2114
+
+Index: configure.ac
+===================================================================
+--- configure.ac (wersja 2113)
++++ configure.ac (wersja 2114)
+@@ -176,7 +176,7 @@
+ LIBS="$LIBS $LIBLTDL"
+ AC_CHECK_FUNCS([lt_dlmutex_register])
+ LIBS=$old_LIBS
+-AC_CHECK_TYPES([lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
++AC_CHECK_TYPES([struct lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
+
+ if test "x$enable_ltdl_install" = "xno" && test "x$ac_cv_lib_ltdl_lt_dlinit" = "xno" ; then
+ AC_MSG_ERROR([[
diff --git a/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch b/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch
new file mode 100644
index 0000000000..9e9e5f55d3
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch
@@ -0,0 +1,48 @@
+Tell where is libltdl from libtool - was needed to get it built with libtool 2.2.4
+
+---
+ configure.ac | 26 +++++++++++++++++++-------
+ 1 file changed, 19 insertions(+), 7 deletions(-)
+
+--- pulseaudio-0.9.10.orig/configure.ac
++++ pulseaudio-0.9.10/configure.ac
+@@ -242,20 +242,32 @@ if test $ret -eq 0 ; then
+ else
+ AC_MSG_RESULT([no])
+ fi
+
+ #### libtool stuff ####
+-
+-AC_LTDL_ENABLE_INSTALL
+-AC_LIBLTDL_INSTALLABLE
+-AC_LIBTOOL_DLOPEN
+-AC_LIBTOOL_WIN32_DLL
++LT_PREREQ([2.2])
++LT_INIT([dlopen win32-dll])
+ AC_PROG_LIBTOOL
+-AC_SUBST(LTDLINCL)
+-AC_SUBST(LIBLTDL)
++#AC_SUBST(LTDLINCL)
++#AC_SUBST(LIBLTDL)
+ AC_CONFIG_SUBDIRS(libltdl)
+
++AC_ARG_WITH(libltdl-libs,
++ [ --with-libltdl-libs=DIR path to libltdl libs], libltdl_libs_prefix=$withval)
++if test x$libltdl_libs_prefix != x; then
++ LIBLTDL="-L${libltdl_libs_prefix}/libltdl.so -lltdl"
++fi
++AC_SUBST(LIBLTDL)
++
++AC_ARG_WITH(libltdl-includes,
++ [ --with-libltdl-includes=DIR path to libltdl includes], libltdl_prefix=$withval)
++if test x$libltdl_prefix != x; then
++ LTDLINCL="-I${libltdl_prefix} ${libltdl_libs_prefix}/libltdl.so"
++fi
++AC_SUBST(LTDLINCL)
++
++
+ old_LIBS=$LIBS
+ LIBS="$LIBS $LIBLTDL"
+ AC_CHECK_FUNCS([lt_dlmutex_register])
+ LIBS=$old_LIBS
+ AC_CHECK_TYPES([struct lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
diff --git a/packages/pulseaudio/pulseaudio-alsa-wrapper.bb b/packages/pulseaudio/pulseaudio-alsa-wrapper.bb
new file mode 100644
index 0000000000..e555d50075
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-alsa-wrapper.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "Meta package to make alsa transparently use pulseaudio"
+LICENSE = "GPLv2"
+
+PR = "r1"
+
+SRC_URI = "file://asound.conf.pulseaudio"
+
+RDEPENDS = "hal \
+ pulseaudio-server \
+ pulseaudio-misc \
+ pulseaudio-module-alsa-sink \
+ pulseaudio-module-alsa-source \
+ pulseaudio-module-hal-detect \
+ pulseaudio-module-volume-restore \
+ pulseaudio-module-default-device-restore \
+ pulseaudio-module-rescue-streams \
+ pulseaudio-module-suspend-on-idle \
+ libasound-module-ctl-pulse \
+ libasound-module-pcm-pulse \
+"
+
+do_install() {
+ install -d ${D}/${sysconfdir}
+ install -m 0644 ${WORKDIR}/asound.conf.pulseaudio ${D}/${sysconfdir}
+}
+
+PACKAGE_ARCH = "all"
+
+pkg_postinst_${PN} () {
+#!/bin/sh
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+mkdir -p /etc/pulse || true
+# Remove existing entries
+if [ -e /etc/pulse/session ] ; then
+ sed -i -e /load-module\ module-hal-detect/d /etc/pulse/session
+fi
+# Load hal-detect module to avoid alsa->pulse-alsa-pulse->.. loops
+echo "load-module module-hal-detect" >> /etc/pulse/session
+}
+
diff --git a/packages/pulseaudio/pulseaudio-esd-wrapper.bb b/packages/pulseaudio/pulseaudio-esd-wrapper.bb
new file mode 100644
index 0000000000..d1ae362c14
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-esd-wrapper.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Drop-in Esound replacement"
+LICENSE = "GPLv2"
+
+PR = "r1"
+
+RCONFLICTS = "esd"
+RREPLACES = "esd"
+
+RDEPENDS = " \
+ pulseaudio-server \
+ pulseaudio-misc \
+ pulseaudio-lib-protocol-esound \
+ pulseaudio-module-esound-compat-spawnfd \
+ pulseaudio-module-esound-compat-spawnpid \
+ pulseaudio-module-esound-protocol-tcp \
+ pulseaudio-module-esound-protocol-unix \
+"
+
+do_install() {
+ install -d ${D}/${bindir}
+ ln -sf ${bindir}/esdcompat ${D}/${bindir}/esd
+}
+
+
+PACKAGE_ARCH = "all"
+
+pkg_postinst_${PN} () {
+#!/bin/sh
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+mkdir -p /etc/pulse || true
+# Remove existing entries
+if [ -e /etc/pulse/session ] ; then
+ sed -i -e /load-module\ module-esound-protocol-unix/d -e /load-module\ module-esound-protocol-tcp/d /etc/pulse/session
+fi
+# Load esound modules
+echo "load-module module-esound-protocol-tcp" >> /etc/pulse/session
+echo "load-module module-esound-protocol-unix" >> /etc/pulse/session
+}
+
diff --git a/packages/pulseaudio/pulseaudio-meta/.mtn2git_empty b/packages/pulseaudio/pulseaudio-meta/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-meta/.mtn2git_empty
diff --git a/packages/pulseaudio/pulseaudio-meta/asound.conf b/packages/pulseaudio/pulseaudio-meta/asound.conf
new file mode 100644
index 0000000000..b435184575
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-meta/asound.conf
@@ -0,0 +1,8 @@
+# set default output to pulseaudio
+pcm.!default {
+ type pulse
+}
+
+ctl.!default {
+ type pulse
+}
diff --git a/packages/pulseaudio/pulseaudio-meta/pulseaudio b/packages/pulseaudio/pulseaudio-meta/pulseaudio
new file mode 100755
index 0000000000..964947376e
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-meta/pulseaudio
@@ -0,0 +1,50 @@
+#!/bin/sh
+#
+# pulseaudio This shell script starts and stops pulseaudio.
+#
+# chkconfig: 345 90 40
+# description: Pulseaudio manages the sound input/output
+# processname: pulseaudio
+
+# Source function library.
+#. /etc/rc.d/init.d/functions
+
+RETVAL=0
+prog="pulseaudio"
+
+start() {
+ echo -n "Starting audio server: "
+ # FIXME once alsa/shm permissions have been fixed, supply --system
+ start-stop-daemon -S -x /usr/bin/pulseaudio -- --no-cpu-limit --resample-method=trivial -D -nF /etc/pulse/session
+
+ if [ $? = 0 ]; then
+ echo "$prog (warning ignores)." # FIXME remove comment on warning
+ else
+ echo "(failed.)"
+ fi
+}
+
+stop() {
+ echo -n "Stopping audio server: "
+ start-stop-daemon -K -x /usr/bin/pulseaudio
+ echo "pulseaudio."
+}
+
+# See how we were called.
+case "$1" in
+ start)
+ start
+ ;;
+ stop)
+ stop
+ ;;
+ restart|reload)
+ stop
+ start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+ exit 1
+esac
+
+exit $RETVAL
diff --git a/packages/pulseaudio/pulseaudio-meta/session b/packages/pulseaudio/pulseaudio-meta/session
new file mode 100644
index 0000000000..55f2c16f26
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-meta/session
@@ -0,0 +1,36 @@
+#!/usr/bin/pulseaudio -nF
+
+#
+# Barebones PA Session File for Devices w/ ALSA
+# (C) Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+#
+
+# Create autoload entries for the device drivers
+add-autoload-sink output module-alsa-sink device=hw:0 sink_name=output
+add-autoload-source input module-alsa-source device=hw:0 source_name=input
+
+# Core protocols
+load-module module-esound-protocol-unix
+load-module module-simple-protocol-tcp
+load-module module-native-protocol-unix
+load-module module-cli-protocol-unix
+
+# Suspend on idle
+load-module module-suspend-on-idle
+
+# Set default sink and source
+set-default-sink output
+set-default-source input
+
+# Don't fail if the audio files referred to below don't exist
+.nofail
+
+# Load an audio to the sample cache for usage with module-x11-bell
+#load-sample-lazy x11-bell /usr/share/openmoko/sounds/notify_doorbell.wav
+#load-module module-x11-bell sample=x11-bell
+
+# Load samples
+#load-sample startup /usr/share/openmoko/sounds/startup_unintrusive.wav
+#load-sample touchscreen /usr/share/openmoko/sounds/touchscreen_click.wav
+#load-sample ringtone /usr/share/openmoko/sounds/ringtone_classy.wav
+
diff --git a/packages/pulseaudio/pulseaudio-meta_0.9.10.bb b/packages/pulseaudio/pulseaudio-meta_0.9.10.bb
new file mode 100644
index 0000000000..0f1dd6a5b6
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-meta_0.9.10.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Pulseaudio Meta package w/ initscript et. al."
+SECTION = "audio"
+RDEPENDS = "\
+ pulseaudio-server \
+ pulseaudio-module-alsa-sink \
+ pulseaudio-module-alsa-source \
+ pulseaudio-module-cli \
+ pulseaudio-module-esound-protocol-unix \
+ pulseaudio-module-simple-protocol-tcp \
+ pulseaudio-module-native-protocol-unix \
+ pulseaudio-module-cli-protocol-unix \
+ pulseaudio-module-suspend-on-idle \
+ gst-plugin-pulse \
+ libasound-module-ctl-pulse \
+ libasound-module-pcm-pulse \
+"
+PR = "r1"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "pulseaudio"
+INITSCRIPT_PARAMS = "defaults 35"
+
+SRC_URI = "\
+ file://pulseaudio \
+ file://session \
+ file://asound.conf \
+"
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/pulseaudio ${D}/${sysconfdir}/init.d/
+ install -d ${D}/${sysconfdir}/pulse
+ install -m 0755 ${WORKDIR}/session ${D}/${sysconfdir}/pulse/session
+ install -m 0644 ${WORKDIR}/asound.conf ${D}/${sysconfdir}
+}
+
+PACKAGE_ARCH = "all"
+
+CONFFILES_${PN} = "\
+ ${sysconfdir}/pulse/session \
+ ${sysconfdir}/asound.conf \
+"
diff --git a/packages/pulseaudio/pulse.inc b/packages/pulseaudio/pulseaudio.inc
index 4b13980cc4..4b13980cc4 100644
--- a/packages/pulseaudio/pulse.inc
+++ b/packages/pulseaudio/pulseaudio.inc
diff --git a/packages/pulseaudio/pulseaudio_0.9.10.bb b/packages/pulseaudio/pulseaudio_0.9.10.bb
index 5a445a45cb..8c858f9015 100644
--- a/packages/pulseaudio/pulseaudio_0.9.10.bb
+++ b/packages/pulseaudio/pulseaudio_0.9.10.bb
@@ -1,16 +1,26 @@
-require pulse.inc
+require pulseaudio.inc
DEPENDS += "dbus"
-PR = "r1"
+PR = "r3"
-# this is not correct (see below)
SRC_URI += "\
file://disable-using-glibc-tls.patch;patch=1 \
file://libpulsedsp-references-libpulsecore.patch;patch=1 \
file://pa-drop-caps-returns-void.patch;patch=1 \
+# file://libtool2.patch;patch=1 \
+ file://2113.diff;patch=1;pnum=0 \
+ file://2114.diff;patch=1;pnum=0 \
"
+do_compile_prepend() {
+ cd ${S}
+ mkdir -p ${S}/libltdl
+ cp ${STAGING_LIBDIR}/libltdl* ${S}/libltdl
+}
+
+
# problems w/ pulseaudio 0.9.10 atm:
# 1.) needs libltdl >= 1.5.24 (yes, any older version will NOT work at runtime)
# 2.) doesn't build w/ glibc TLS support (hence patched out)
# 3.) fails with hierarchical pthread stuff w/ gst-pulse (hence patched out)
+
diff --git a/packages/pulseaudio/pulseaudio_0.9.6.bb b/packages/pulseaudio/pulseaudio_0.9.6.bb
index 56b717aac7..8944b664c0 100644
--- a/packages/pulseaudio/pulseaudio_0.9.6.bb
+++ b/packages/pulseaudio/pulseaudio_0.9.6.bb
@@ -1,4 +1,4 @@
-require pulse.inc
+require pulseaudio.inc
-PR = "r7"
+PR = "r8"
diff --git a/packages/pulseaudio/pulseaudio_0.9.9.bb b/packages/pulseaudio/pulseaudio_0.9.9.bb
index f38595e5dd..764f891654 100644
--- a/packages/pulseaudio/pulseaudio_0.9.9.bb
+++ b/packages/pulseaudio/pulseaudio_0.9.9.bb
@@ -1,7 +1,7 @@
-require pulse.inc
+require pulseaudio.inc
DEPENDS += "dbus"
-PR = "r4"
+PR = "r5"
# this is not correct (see below)
SRC_URI += "\