summaryrefslogtreecommitdiff
path: root/packages/powertop/powertop_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/powertop/powertop_1.0.bb')
-rw-r--r--packages/powertop/powertop_1.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/powertop/powertop_1.0.bb b/packages/powertop/powertop_1.0.bb
new file mode 100644
index 0000000000..a06397bfc4
--- /dev/null
+++ b/packages/powertop/powertop_1.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
+LICENSE = "GPLv2"
+
+SRC_URI = "http://www.linuxpowertop.org/download/powertop-${PV}.tar.gz"
+
+S = "${WORKDIR}/${PN}"
+
+
+do_compile() {
+ ${CC} -Wall -W -O1 -g powertop.c config.c -o powertop
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 powertop ${D}${bindir}
+}
+