summaryrefslogtreecommitdiff
path: root/packages/portmap/portmap_6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/portmap/portmap_6.0.bb')
-rw-r--r--packages/portmap/portmap_6.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/portmap/portmap_6.0.bb b/packages/portmap/portmap_6.0.bb
new file mode 100644
index 0000000000..4b8b8c8d5c
--- /dev/null
+++ b/packages/portmap/portmap_6.0.bb
@@ -0,0 +1,18 @@
+require portmap.inc
+
+SRC_URI = "http://neil.brown.name/portmap/portmap-6.0.tgz \
+ file://destdir-no-strip.patch;patch=1 \
+ file://no-tcpd-support.patch;patch=1 \
+ file://no-libwrap.patch;patch=1;pnum=0 \
+ file://portmap.init "
+
+S = "${WORKDIR}/${PN}_${PV}/"
+
+CPPFLAGS += "-DFACILITY=LOG_DAEMON -DENABLE_DNS"
+
+fakeroot do_install() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/portmap.init ${D}${sysconfdir}/init.d/portmap
+ install -d ${D}${mandir}/man8/ ${D}${base_sbindir}
+ oe_runmake install DESTDIR=${D}
+}