summaryrefslogtreecommitdiff
path: root/packages/php/php_5.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/php/php_5.2.0.bb')
-rw-r--r--packages/php/php_5.2.0.bb33
1 files changed, 3 insertions, 30 deletions
diff --git a/packages/php/php_5.2.0.bb b/packages/php/php_5.2.0.bb
index ea4b0eaf7c..4ed88cf411 100644
--- a/packages/php/php_5.2.0.bb
+++ b/packages/php/php_5.2.0.bb
@@ -1,22 +1,12 @@
-SECTION = "console/network"
-DESCRIPTION = "A server-side, HTML-embedded scripting language. This package provides the CGI."
-LICENSE = "PHP"
-DEPENDS = "zlib libxml2 mysql virtual/libiconv php-native"
+require php.inc
-SRC_URI = "http://us2.php.net/distributions/php-${PV}.tar.bz2\
- file://autotools.patch;patch=1 \
- file://acinclude-xml2-config.patch;patch=1 \
- file://pear-makefile.patch;patch=1 \
- "
-S = "${WORKDIR}/php-${PV}"
-PR = "r1"
+PR = "r2"
-inherit autotools
+SRC_URI += "file://pear-makefile.patch;patch=1 "
export THREADS="pthread"
export LIBS=" -lpthread "
-CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
EXTRA_OECONF = " --without-iconv \
--enable-discard-path \
--enable-sockets \
@@ -29,28 +19,16 @@ EXTRA_OECONF = " --without-iconv \
--with-mysqli="${STAGING_BINDIR_NATIVE}/mysql_config" \
"
-
-
-
-# Uncomment the following two lines, and comment the above to enable PEAR
EXTRA_OECONF += " --with-pear-php-cli=${STAGING_BINDIR} --with-libxml-dir=${STAGING_BINDIR}"
export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
export PHP_NATIVE_DIR="${STAGING_BINDIR_NATIVE}"
export PHP_PEAR_PHP_BIN="/usr/bin/php"
-acpaths = ""
-
do_configure_append() {
find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
}
-do_install () {
- oe_runmake 'INSTALL_ROOT=${D}' install
-}
-
-
-
PACKAGES = "${PN}-dbg \
${PN}-cli \
${PN}-pear \
@@ -76,17 +54,12 @@ FILES_${PN}-pear ="/usr/bin/pear* /usr/bin/pecl \
/usr/lib/php/.depdb /usr/lib/php/.depdblock /usr/lib/php/.filemap \
/usr/lib/php/.lock"
-
FILES_${PN}-dev ="/usr/include/php /usr/include/build \
/usr/bin/phpize /usr/bin/php-config"
FILES_${PN} ="/usr/lib/php"
FILES_${PN} +="/usr/bin"
-
-
RDEPENDS_${PN}-pear =${PN}
RDEPENDS_${PN}-cli =${PN}
RDEPENDS_${PN}-dev =${PN}
-
-