summaryrefslogtreecommitdiff
path: root/packages/php/php_5.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/php/php_5.2.0.bb')
-rw-r--r--packages/php/php_5.2.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/php/php_5.2.0.bb b/packages/php/php_5.2.0.bb
new file mode 100644
index 0000000000..919d96f8e3
--- /dev/null
+++ b/packages/php/php_5.2.0.bb
@@ -0,0 +1,41 @@
+SECTION = "console/network"
+DESCRIPTION = "A server-side, HTML-embedded scripting language. This package provides the CGI."
+LICENSE = "PHP"
+DEPENDS = "zlib libxml2 mysql libiconv"
+SRC_URI = "http://us2.php.net/distributions/php-${PV}.tar.bz2\
+ file://autotools.patch;patch=1 \
+ file://acinclude-xml2-config.patch;patch=1 \
+ "
+S = "${WORKDIR}/php-${PV}"
+PR = "r0"
+
+inherit autotools
+
+export THREADS="pthread"
+export LIBS=" -lpthread "
+
+CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+EXTRA_OECONF = " --without-iconv \
+ --enable-discard-path \
+ --enable-sockets \
+ --enable-memory-limit \
+ --enable-wddx \
+ --with-zlib"
+
+EXTRA_OECONF += " --without-pear --with-libxml-dir=${STAGING_BINDIR} "
+export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
+
+# Uncomment the following two lines, and comment the above to enable PEAR
+#EXTRA_OECONF += " --with-pear-php-cli=${STAGING_BINDIR_NATIVE}/php"
+#DEPENDS += " php-native"
+
+acpaths = ""
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
+}
+
+do_install () {
+ oe_runmake 'INSTALL_ROOT=${D}' install
+}
+