summaryrefslogtreecommitdiff
path: root/packages/pcre/pcre_4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/pcre/pcre_4.4.bb')
-rw-r--r--packages/pcre/pcre_4.4.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/packages/pcre/pcre_4.4.bb b/packages/pcre/pcre_4.4.bb
index 5ba7a1298b..609a808891 100644
--- a/packages/pcre/pcre_4.4.bb
+++ b/packages/pcre/pcre_4.4.bb
@@ -19,9 +19,11 @@ CFLAGS_append = " -D_REENTRANT"
EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000"
do_compile () {
- ${BUILD_CC} -DLINK_SIZE=2 -I${S}/include -c dftables.c
- ${BUILD_CC} dftables.o -o dftables
- oe_runmake
+ # The generation of dftables can lead to timestamp problems with ccache
+ # because the generated config.h seems newer. It is sufficient to ensure that the
+ # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
+ # only used for this).
+ oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC}"
}
do_stage () {