summaryrefslogtreecommitdiff
path: root/packages/pcmciautils
diff options
context:
space:
mode:
Diffstat (limited to 'packages/pcmciautils')
-rw-r--r--packages/pcmciautils/pcmciautils-013/makefile_fix.patch20
-rw-r--r--packages/pcmciautils/pcmciautils-013/version_workaround.patch16
-rw-r--r--packages/pcmciautils/pcmciautils-014/makefile_fix.patch88
-rw-r--r--packages/pcmciautils/pcmciautils-014/version_workaround.patch16
-rw-r--r--packages/pcmciautils/pcmciautils-015/ccdv.patch34
-rw-r--r--packages/pcmciautils/pcmciautils-015/makefile_fix.patch88
-rw-r--r--packages/pcmciautils/pcmciautils-015/version_workaround.patch16
-rw-r--r--packages/pcmciautils/pcmciautils.inc30
-rw-r--r--packages/pcmciautils/pcmciautils/modalias_update.patch56
-rw-r--r--packages/pcmciautils/pcmciautils_010.bb5
-rw-r--r--packages/pcmciautils/pcmciautils_013.bb7
-rw-r--r--packages/pcmciautils/pcmciautils_014.bb7
-rw-r--r--packages/pcmciautils/pcmciautils_015.bb8
13 files changed, 0 insertions, 391 deletions
diff --git a/packages/pcmciautils/pcmciautils-013/makefile_fix.patch b/packages/pcmciautils/pcmciautils-013/makefile_fix.patch
deleted file mode 100644
index a45f9e20e3..0000000000
--- a/packages/pcmciautils/pcmciautils-013/makefile_fix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Hardcoded paths are bad...
-
-Index: pcmciautils-013/Makefile
-===================================================================
---- pcmciautils-013.orig/Makefile 2006-03-26 11:56:41.000000000 +0100
-+++ pcmciautils-013/Makefile 2006-05-09 22:10:16.000000000 +0100
-@@ -69,11 +69,11 @@
- mandir = ${prefix}/usr/share/man
- srcdir = .
-
--INSTALL = /usr/bin/install -c
-+INSTALL = install -c
- INSTALL_PROGRAM = ${INSTALL}
- INSTALL_DATA = ${INSTALL} -m 644
- INSTALL_SCRIPT = ${INSTALL_PROGRAM}
--SYMLINK = /usr/bin/ln -sf
-+SYMLINK = ln -sf
-
- # place to put our hotplug scripts nodes
- hotplugdir = ${etcdir}/hotplug
diff --git a/packages/pcmciautils/pcmciautils-013/version_workaround.patch b/packages/pcmciautils/pcmciautils-013/version_workaround.patch
deleted file mode 100644
index ff34e139b3..0000000000
--- a/packages/pcmciautils/pcmciautils-013/version_workaround.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-PCMCIAUTILS_VERSION is specified on the commandline but doesn't compile properly
-under arm gcc 3.4.x so we work around it.
-
-Index: pcmciautils-013/src/pccardctl.c
-===================================================================
---- pcmciautils-013.orig/src/pccardctl.c 2006-03-26 11:56:41.000000000 +0100
-+++ pcmciautils-013/src/pccardctl.c 2006-05-09 22:11:09.000000000 +0100
-@@ -350,7 +350,7 @@
- }
-
- static void print_header(void) {
-- printf("pcmciautils %s\n", PCMCIAUTILS_VERSION);
-+ printf("pcmciautils 013\n");
- printf("Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds\n");
- printf("Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.\n");
- }
diff --git a/packages/pcmciautils/pcmciautils-014/makefile_fix.patch b/packages/pcmciautils/pcmciautils-014/makefile_fix.patch
deleted file mode 100644
index f5bb64b9bd..0000000000
--- a/packages/pcmciautils/pcmciautils-014/makefile_fix.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-Hardcoded paths are bad...
-
-Index: pcmciautils-014/Makefile
-===================================================================
---- pcmciautils-014.orig/Makefile 2006-06-01 11:07:52.000000000 +0200
-+++ pcmciautils-014/Makefile 2006-10-29 13:50:25.000000000 +0100
-@@ -69,7 +69,7 @@
- mandir = ${prefix}/usr/share/man
- srcdir = .
-
--INSTALL = /usr/bin/install -c
-+INSTALL = install -c
- INSTALL_PROGRAM = ${INSTALL}
- INSTALL_DATA = ${INSTALL} -m 644
- INSTALL_SCRIPT = ${INSTALL_PROGRAM}
---- pcmciautils-014/Makefile~ 2007-05-25 19:40:39.000000000 +0200
-+++ pcmciautils-014/Makefile 2007-05-25 19:40:39.000000000 +0200
-@@ -258,28 +258,29 @@
-
- install-hotplug:
- $(INSTALL) -d $(DESTDIR)$(hotplugdir)
-- $(INSTALL_PROGRAM) -D hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
-- $(INSTALL_PROGRAM) -D hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
-+ $(INSTALL_PROGRAM) hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
-+ $(INSTALL_PROGRAM) hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
-
- uninstall-hotplug:
- - rm -f $(DESTDIR)$(hotplugdir)/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.rc
-
- install-socket-hotplug:
-- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
-- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
-+ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
-+ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
-
- uninstall-socket-hotplug:
- - rm -f $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
- install-socket-tools:
-- $(INSTALL_PROGRAM) -D $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
-+ $(INSTALL) -d $(DESTDIR)$(sbindir)
-+ $(INSTALL_PROGRAM) $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
-
- uninstall-socket-tools:
- - rm -f $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
-
- install-tools:
- $(INSTALL) -d $(DESTDIR)$(sbindir)
-- $(INSTALL_PROGRAM) -D $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
-- $(INSTALL_PROGRAM) -D $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
-+ $(INSTALL_PROGRAM) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
-+ $(INSTALL_PROGRAM) $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
- $(SYMLINK) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(LSPCMCIA)
-
- uninstall-tools:
-@@ -289,18 +290,20 @@
-
- install-config:
- $(INSTALL) -d $(DESTDIR)$(pcmciaconfdir)
-- $(INSTALL_DATA) -D config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
-+ $(INSTALL_DATA) config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
-
- uninstall-config:
- # - rm -f $(DESTDIR)$(pcmciaconfdir)/config.opts
-
- install-udev:
-- $(INSTALL_DATA) -D $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
-+ $(INSTALL) -d $(DESTDIR)$(udevrulesdir)
-+ $(INSTALL_DATA) $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
-
- uninstall-udev:
- - rm -f $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
-
- install-man:
-+ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
- $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
- $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
-
---- pcmciautils-014/Makefile~ 2007-05-25 19:43:01.000000000 +0200
-+++ pcmciautils-014/Makefile 2007-05-25 19:43:01.000000000 +0200
-@@ -304,7 +304,7 @@
-
- install-man:
- $(INSTALL) -d $(DESTDIR)$(mandir)/man8
-- $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
-+ $(INSTALL_DATA) man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
- $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
-
- uninstall-man:
diff --git a/packages/pcmciautils/pcmciautils-014/version_workaround.patch b/packages/pcmciautils/pcmciautils-014/version_workaround.patch
deleted file mode 100644
index 962aa4e246..0000000000
--- a/packages/pcmciautils/pcmciautils-014/version_workaround.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-PCMCIAUTILS_VERSION is specified on the commandline but doesn't compile properly
-under arm gcc 3.4.x so we work around it.
-
-Index: pcmciautils-013/src/pccardctl.c
-===================================================================
---- pcmciautils-013.orig/src/pccardctl.c 2006-03-26 11:56:41.000000000 +0100
-+++ pcmciautils-013/src/pccardctl.c 2006-05-09 22:11:09.000000000 +0100
-@@ -350,7 +350,7 @@
- }
-
- static void print_header(void) {
-- printf("pcmciautils %s\n", PCMCIAUTILS_VERSION);
-+ printf("pcmciautils 014\n");
- printf("Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds\n");
- printf("Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.\n");
- }
diff --git a/packages/pcmciautils/pcmciautils-015/ccdv.patch b/packages/pcmciautils/pcmciautils-015/ccdv.patch
deleted file mode 100644
index 460e3938aa..0000000000
--- a/packages/pcmciautils/pcmciautils-015/ccdv.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: Olivier Blin <blino@mandriva.com>
-Date: Wed, 13 Aug 2008 20:30:14 +0000 (+0200)
-Subject: fix parallel build of ccdv
-X-Git-Url: http://git.kernel.org/?p=linux%2Fpcmcia%2Fpcmciautils.git;a=commitdiff_plain;h=ff72508f29567028597d8816bdf8b55c3c61a314
-
-fix parallel build of ccdv
-
-Parallel build was broken because ccdv was not necessarily built
-before the object files were built (occured with make -j4).
-
-Signed-off-by: Olivier Blin <blino@mandriva.com>
-Signed-off-by: Dominik Brodowski <linux@dominikbrodowski.net>
----
-
-diff --git a/Makefile b/Makefile
-index cc30ae4..e1d7c85 100644
---- a/Makefile
-+++ b/Makefile
-@@ -208,11 +208,12 @@ UDEV_RULES += udev/rules-end
-
- all: ccdv $(PCCARDCTL) $(PCMCIA_CHECK_BROKEN_CIS) $(PCMCIA_SOCKET_STARTUP_BUILD) udevrules
-
--ccdv:
-+ccdv: build/ccdv
-+build/ccdv: build/ccdv.c
- @echo "Building ccdv"
-- @$(HOSTCC) -O1 build/ccdv.c -o build/ccdv
-+ @$(HOSTCC) -O1 $< -o $@
-
--.c.o:
-+%.o : %.c ccdv
- $(QUIET) $(CC) $(CFLAGS) -c -o $@ $<
-
- %.c %.h : %.y
diff --git a/packages/pcmciautils/pcmciautils-015/makefile_fix.patch b/packages/pcmciautils/pcmciautils-015/makefile_fix.patch
deleted file mode 100644
index f5bb64b9bd..0000000000
--- a/packages/pcmciautils/pcmciautils-015/makefile_fix.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-Hardcoded paths are bad...
-
-Index: pcmciautils-014/Makefile
-===================================================================
---- pcmciautils-014.orig/Makefile 2006-06-01 11:07:52.000000000 +0200
-+++ pcmciautils-014/Makefile 2006-10-29 13:50:25.000000000 +0100
-@@ -69,7 +69,7 @@
- mandir = ${prefix}/usr/share/man
- srcdir = .
-
--INSTALL = /usr/bin/install -c
-+INSTALL = install -c
- INSTALL_PROGRAM = ${INSTALL}
- INSTALL_DATA = ${INSTALL} -m 644
- INSTALL_SCRIPT = ${INSTALL_PROGRAM}
---- pcmciautils-014/Makefile~ 2007-05-25 19:40:39.000000000 +0200
-+++ pcmciautils-014/Makefile 2007-05-25 19:40:39.000000000 +0200
-@@ -258,28 +258,29 @@
-
- install-hotplug:
- $(INSTALL) -d $(DESTDIR)$(hotplugdir)
-- $(INSTALL_PROGRAM) -D hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
-- $(INSTALL_PROGRAM) -D hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
-+ $(INSTALL_PROGRAM) hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
-+ $(INSTALL_PROGRAM) hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
-
- uninstall-hotplug:
- - rm -f $(DESTDIR)$(hotplugdir)/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.rc
-
- install-socket-hotplug:
-- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
-- $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
-+ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
-+ $(INSTALL_PROGRAM) hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
-
- uninstall-socket-hotplug:
- - rm -f $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
- install-socket-tools:
-- $(INSTALL_PROGRAM) -D $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
-+ $(INSTALL) -d $(DESTDIR)$(sbindir)
-+ $(INSTALL_PROGRAM) $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
-
- uninstall-socket-tools:
- - rm -f $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
-
- install-tools:
- $(INSTALL) -d $(DESTDIR)$(sbindir)
-- $(INSTALL_PROGRAM) -D $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
-- $(INSTALL_PROGRAM) -D $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
-+ $(INSTALL_PROGRAM) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
-+ $(INSTALL_PROGRAM) $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
- $(SYMLINK) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(LSPCMCIA)
-
- uninstall-tools:
-@@ -289,18 +290,20 @@
-
- install-config:
- $(INSTALL) -d $(DESTDIR)$(pcmciaconfdir)
-- $(INSTALL_DATA) -D config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
-+ $(INSTALL_DATA) config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
-
- uninstall-config:
- # - rm -f $(DESTDIR)$(pcmciaconfdir)/config.opts
-
- install-udev:
-- $(INSTALL_DATA) -D $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
-+ $(INSTALL) -d $(DESTDIR)$(udevrulesdir)
-+ $(INSTALL_DATA) $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
-
- uninstall-udev:
- - rm -f $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
-
- install-man:
-+ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
- $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
- $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
-
---- pcmciautils-014/Makefile~ 2007-05-25 19:43:01.000000000 +0200
-+++ pcmciautils-014/Makefile 2007-05-25 19:43:01.000000000 +0200
-@@ -304,7 +304,7 @@
-
- install-man:
- $(INSTALL) -d $(DESTDIR)$(mandir)/man8
-- $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
-+ $(INSTALL_DATA) man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
- $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
-
- uninstall-man:
diff --git a/packages/pcmciautils/pcmciautils-015/version_workaround.patch b/packages/pcmciautils/pcmciautils-015/version_workaround.patch
deleted file mode 100644
index 962aa4e246..0000000000
--- a/packages/pcmciautils/pcmciautils-015/version_workaround.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-PCMCIAUTILS_VERSION is specified on the commandline but doesn't compile properly
-under arm gcc 3.4.x so we work around it.
-
-Index: pcmciautils-013/src/pccardctl.c
-===================================================================
---- pcmciautils-013.orig/src/pccardctl.c 2006-03-26 11:56:41.000000000 +0100
-+++ pcmciautils-013/src/pccardctl.c 2006-05-09 22:11:09.000000000 +0100
-@@ -350,7 +350,7 @@
- }
-
- static void print_header(void) {
-- printf("pcmciautils %s\n", PCMCIAUTILS_VERSION);
-+ printf("pcmciautils 014\n");
- printf("Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds\n");
- printf("Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.\n");
- }
diff --git a/packages/pcmciautils/pcmciautils.inc b/packages/pcmciautils/pcmciautils.inc
deleted file mode 100644
index f9ef159a5c..0000000000
--- a/packages/pcmciautils/pcmciautils.inc
+++ /dev/null
@@ -1,30 +0,0 @@
-DESCRIPTION = "Linux Kernel 2.6 Userland Utilities for the PCMCIA Subsystem"
-DEPENDS = "sysfsutils"
-RDEPENDS = "udev module-init-tools"
-HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
-SECTION = "kernel/userland"
-PRIORITY = "optional"
-LICENSE = "GPLv2"
-
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2"
-
-S = "${WORKDIR}/pcmciautils-${PV}"
-
-export HOSTCC = "${BUILD_CC}"
-export etcdir = "${sysconfdir}"
-export sbindir = "${base_sbindir}"
-export pcmciaconfdir = "${sysconfdir}/pcmcia"
-export udevrulesdir = "${sysconfdir}/udev/rules.d"
-export UDEV = "1"
-LD = "${CC}"
-CFLAGS =+ "-I${S}/src"
-
-PARALLEL_MAKE = ""
-EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs'"
-
-do_install () {
- oe_runmake 'DESTDIR=${D}' install
-}
-
-CONFFILES_${PN} += "${sysconfdir}/pcmcia/config.opts"
-RCONFLICTS_${PN} += "pcmcia-cs"
diff --git a/packages/pcmciautils/pcmciautils/modalias_update.patch b/packages/pcmciautils/pcmciautils/modalias_update.patch
deleted file mode 100644
index 5727442b59..0000000000
--- a/packages/pcmciautils/pcmciautils/modalias_update.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From: Miklos Vajna <vmiklos@frugalware.org>
-Date: Fri, 3 Nov 2006 16:33:38 +0000 (-0500)
-Subject: [PATCH] fix for udev-094
-X-Git-Url: http://git.kernel.org/?p=linux%2Fpcmcia%2Fpcmciautils.git;a=commitdiff_plain;h=3a5217492c1f95711b30f4e27c51563dff6ceb3e
-
-[PATCH] fix for udev-094
-
-from udev's release notes:
-
-"udev 094
-========
-The built-in MODALIAS key and substitution is removed.
-(...)
-udev 080
-========
-(...)
-MODALIAS and $modalias is not needed and will be removed from one of
-the next udev versions, replace it in all rules with ENV{MODALIAS} or
-the sysfs "modalias" value."
-
-here is a patch to fix this issue
-
-Signed-off-by: Miklos Vajna <vmiklos@frugalware.org>
-Signed-off-by: Dominik Brodowski <linux@dominikbrodowski.net>
----
-
-diff --git a/udev/rules-base b/udev/rules-base
-index c6d14de..6ed3a27 100644
---- a/udev/rules-base
-+++ b/udev/rules-base
-@@ -3,12 +3,12 @@
- # are so broken that we need to read out random bytes of it
- # instead of the manufactor, card or product ID. Then the
- # matching is done in userspace.
--ACTION=="add", SUBSYSTEM=="pcmcia", MODALIAS=="?*", \
-+ACTION=="add", SUBSYSTEM=="pcmcia", ENV{MODALIAS}=="?*", \
- RUN+="/sbin/pcmcia-check-broken-cis"
-
- # However, the "weak" matching by func_id is only allowed _after_ modprobe
- # returns, so that "strong" matches have a higher priority.
--ACTION=="add", SUBSYSTEM=="pcmcia", MODALIAS=="?*", \
-+ACTION=="add", SUBSYSTEM=="pcmcia", ENV{MODALIAS}=="?*", \
- RUN+="/bin/sh -c 'echo 1 > /sys/$devpath/allow_func_id_match'"
-
- # PCMCIA sockets:
-diff --git a/udev/rules-modprobe b/udev/rules-modprobe
-index ea1f44a..a13b2ad 100644
---- a/udev/rules-modprobe
-+++ b/udev/rules-modprobe
-@@ -1,3 +1,3 @@
--# modprobe $modalias loads all possibly appropriate modules
--ACTION=="add", SUBSYSTEM=="pcmcia", MODALIAS=="?*", \
-- RUN+="/sbin/modprobe $modalias"
-+# modprobe $env{MODALIAS} loads all possibly appropriate modules
-+ACTION=="add", SUBSYSTEM=="pcmcia", ENV{MODALIAS}=="?*", \
-+ RUN+="/sbin/modprobe $env{MODALIAS}"
diff --git a/packages/pcmciautils/pcmciautils_010.bb b/packages/pcmciautils/pcmciautils_010.bb
deleted file mode 100644
index bcebb5f624..0000000000
--- a/packages/pcmciautils/pcmciautils_010.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-require pcmciautils.inc
-
-PR = "r3"
-
-CFLAGS =+ '-DPCMCIAUTILS_VERSION=010'
diff --git a/packages/pcmciautils/pcmciautils_013.bb b/packages/pcmciautils/pcmciautils_013.bb
deleted file mode 100644
index 72a78b0780..0000000000
--- a/packages/pcmciautils/pcmciautils_013.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require pcmciautils.inc
-
-PR = "r1"
-
-SRC_URI += "file://makefile_fix.patch;patch=1 \
- file://version_workaround.patch;patch=1 \
- file://modalias_update.patch;patch=1"
diff --git a/packages/pcmciautils/pcmciautils_014.bb b/packages/pcmciautils/pcmciautils_014.bb
deleted file mode 100644
index 72a78b0780..0000000000
--- a/packages/pcmciautils/pcmciautils_014.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require pcmciautils.inc
-
-PR = "r1"
-
-SRC_URI += "file://makefile_fix.patch;patch=1 \
- file://version_workaround.patch;patch=1 \
- file://modalias_update.patch;patch=1"
diff --git a/packages/pcmciautils/pcmciautils_015.bb b/packages/pcmciautils/pcmciautils_015.bb
deleted file mode 100644
index 44a3d59dc6..0000000000
--- a/packages/pcmciautils/pcmciautils_015.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require pcmciautils.inc
-
-PR = "r0"
-
-SRC_URI += "file://makefile_fix.patch;patch=1 \
- file://version_workaround.patch;patch=1 \
- file://ccdv.patch;patch=1 \
- "