summaryrefslogtreecommitdiff
path: root/packages/parted/parted_1.8.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/parted/parted_1.8.7.bb')
-rw-r--r--packages/parted/parted_1.8.7.bb19
1 files changed, 11 insertions, 8 deletions
diff --git a/packages/parted/parted_1.8.7.bb b/packages/parted/parted_1.8.7.bb
index dcb3ad7cb4..59e3aeaece 100644
--- a/packages/parted/parted_1.8.7.bb
+++ b/packages/parted/parted_1.8.7.bb
@@ -3,25 +3,28 @@ HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
LICENSE = "GPLv2"
SECTION = "console/tools"
DEPENDS = "readline e2fsprogs-libs"
-PR = "r1"
+PR = "r2"
-SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz"
+SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz \
+ file://syscalls.h \
+ file://syscalls.patch;patch=1 \
+ file://cross-gross-hack.patch;patch=1"
EXTRA_OECONF = "--disable-Werror"
inherit autotools pkgconfig
+do_configure_prepend() {
+ cp ${WORKDIR}/syscalls.h ${S}/libparted/arch/
+}
+
do_configure() {
- libtoolize --force
gnu-configize
+ libtoolize --force
+ autoconf
oe_runconf
}
do_stage() {
autotools_stage_all
}
-
-# Requires autoconf 2.61. Without it, will build, but there
-# will be link errors when some other package will link against
-# libparted.
-DEFAULT_PREFERENCE = "-1"