summaryrefslogtreecommitdiff
path: root/packages/parted/parted_1.8.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/parted/parted_1.8.7.bb')
-rw-r--r--packages/parted/parted_1.8.7.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/parted/parted_1.8.7.bb b/packages/parted/parted_1.8.7.bb
new file mode 100644
index 0000000000..59e3aeaece
--- /dev/null
+++ b/packages/parted/parted_1.8.7.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "parted, the GNU partition resizing program"
+HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
+LICENSE = "GPLv2"
+SECTION = "console/tools"
+DEPENDS = "readline e2fsprogs-libs"
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz \
+ file://syscalls.h \
+ file://syscalls.patch;patch=1 \
+ file://cross-gross-hack.patch;patch=1"
+
+EXTRA_OECONF = "--disable-Werror"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ cp ${WORKDIR}/syscalls.h ${S}/libparted/arch/
+}
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ autoconf
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}