summaryrefslogtreecommitdiff
path: root/packages/pango/pango-1.2.5/m4.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/pango/pango-1.2.5/m4.patch')
-rw-r--r--packages/pango/pango-1.2.5/m4.patch502
1 files changed, 502 insertions, 0 deletions
diff --git a/packages/pango/pango-1.2.5/m4.patch b/packages/pango/pango-1.2.5/m4.patch
index e69de29bb2..ec92211199 100644
--- a/packages/pango/pango-1.2.5/m4.patch
+++ b/packages/pango/pango-1.2.5/m4.patch
@@ -0,0 +1,502 @@
+--- /dev/null
++++ pango-1.2.5/m4/glib-2.0.m4
+@@ -0,0 +1,212 @@
++# Configure paths for GLIB
++# Owen Taylor 1997-2001
++
++dnl AM_PATH_GLIB_2_0([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
++dnl Test for GLIB, and define GLIB_CFLAGS and GLIB_LIBS, if gmodule, gobject or
++dnl gthread is specified in MODULES, pass to pkg-config
++dnl
++AC_DEFUN(AM_PATH_GLIB_2_0,
++[dnl
++dnl Get the cflags and libraries from pkg-config
++dnl
++AC_ARG_ENABLE(glibtest, [ --disable-glibtest do not try to compile and run a test GLIB program],
++ , enable_glibtest=yes)
++
++ pkg_config_args=glib-2.0
++ for module in . $4
++ do
++ case "$module" in
++ gmodule)
++ pkg_config_args="$pkg_config_args gmodule-2.0"
++ ;;
++ gobject)
++ pkg_config_args="$pkg_config_args gobject-2.0"
++ ;;
++ gthread)
++ pkg_config_args="$pkg_config_args gthread-2.0"
++ ;;
++ esac
++ done
++
++ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
++
++ no_glib=""
++
++ if test x$PKG_CONFIG != xno ; then
++ if $PKG_CONFIG --atleast-pkgconfig-version 0.7 ; then
++ :
++ else
++ echo *** pkg-config too old; version 0.7 or better required.
++ no_glib=yes
++ PKG_CONFIG=no
++ fi
++ else
++ no_glib=yes
++ fi
++
++ min_glib_version=ifelse([$1], ,2.0.0,$1)
++ AC_MSG_CHECKING(for GLIB - version >= $min_glib_version)
++
++ if test x$PKG_CONFIG != xno ; then
++ ## don't try to run the test against uninstalled libtool libs
++ if $PKG_CONFIG --uninstalled $pkg_config_args; then
++ echo "Will use uninstalled version of GLib found in PKG_CONFIG_PATH"
++ enable_glibtest=no
++ fi
++
++ if $PKG_CONFIG --atleast-version $min_glib_version $pkg_config_args; then
++ :
++ else
++ no_glib=yes
++ fi
++ fi
++
++ if test x"$no_glib" = x ; then
++ GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`
++ GOBJECT_QUERY=`$PKG_CONFIG --variable=gobject_query glib-2.0`
++ GLIB_MKENUMS=`$PKG_CONFIG --variable=glib_mkenums glib-2.0`
++
++ GLIB_CFLAGS=`$PKG_CONFIG --cflags $pkg_config_args`
++ GLIB_LIBS=`$PKG_CONFIG --libs $pkg_config_args`
++ glib_config_major_version=`$PKG_CONFIG --modversion glib-2.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++ glib_config_minor_version=`$PKG_CONFIG --modversion glib-2.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++ glib_config_micro_version=`$PKG_CONFIG --modversion glib-2.0 | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++ if test "x$enable_glibtest" = "xyes" ; then
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="$CFLAGS $GLIB_CFLAGS"
++ LIBS="$GLIB_LIBS $LIBS"
++dnl
++dnl Now check if the installed GLIB is sufficiently new. (Also sanity
++dnl checks the results of pkg-config to some extent)
++dnl
++ rm -f conf.glibtest
++ AC_TRY_RUN([
++#include <glib.h>
++#include <stdio.h>
++#include <stdlib.h>
++
++int
++main ()
++{
++ int major, minor, micro;
++ char *tmp_version;
++
++ system ("touch conf.glibtest");
++
++ /* HP/UX 9 (%@#!) writes to sscanf strings */
++ tmp_version = g_strdup("$min_glib_version");
++ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
++ printf("%s, bad version string\n", "$min_glib_version");
++ exit(1);
++ }
++
++ if ((glib_major_version != $glib_config_major_version) ||
++ (glib_minor_version != $glib_config_minor_version) ||
++ (glib_micro_version != $glib_config_micro_version))
++ {
++ printf("\n*** 'pkg-config --modversion glib-2.0' returned %d.%d.%d, but GLIB (%d.%d.%d)\n",
++ $glib_config_major_version, $glib_config_minor_version, $glib_config_micro_version,
++ glib_major_version, glib_minor_version, glib_micro_version);
++ printf ("*** was found! If pkg-config was correct, then it is best\n");
++ printf ("*** to remove the old version of GLib. You may also be able to fix the error\n");
++ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
++ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
++ printf("*** required on your system.\n");
++ printf("*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH\n");
++ printf("*** to point to the correct configuration files\n");
++ }
++ else if ((glib_major_version != GLIB_MAJOR_VERSION) ||
++ (glib_minor_version != GLIB_MINOR_VERSION) ||
++ (glib_micro_version != GLIB_MICRO_VERSION))
++ {
++ printf("*** GLIB header files (version %d.%d.%d) do not match\n",
++ GLIB_MAJOR_VERSION, GLIB_MINOR_VERSION, GLIB_MICRO_VERSION);
++ printf("*** library (version %d.%d.%d)\n",
++ glib_major_version, glib_minor_version, glib_micro_version);
++ }
++ else
++ {
++ if ((glib_major_version > major) ||
++ ((glib_major_version == major) && (glib_minor_version > minor)) ||
++ ((glib_major_version == major) && (glib_minor_version == minor) && (glib_micro_version >= micro)))
++ {
++ return 0;
++ }
++ else
++ {
++ printf("\n*** An old version of GLIB (%d.%d.%d) was found.\n",
++ glib_major_version, glib_minor_version, glib_micro_version);
++ printf("*** You need a version of GLIB newer than %d.%d.%d. The latest version of\n",
++ major, minor, micro);
++ printf("*** GLIB is always available from ftp://ftp.gtk.org.\n");
++ printf("***\n");
++ printf("*** If you have already installed a sufficiently new version, this error\n");
++ printf("*** probably means that the wrong copy of the pkg-config shell script is\n");
++ printf("*** being found. The easiest way to fix this is to remove the old version\n");
++ printf("*** of GLIB, but you can also set the PKG_CONFIG environment to point to the\n");
++ printf("*** correct copy of pkg-config. (In this case, you will have to\n");
++ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
++ printf("*** so that the correct libraries are found at run-time))\n");
++ }
++ }
++ return 1;
++}
++],, no_glib=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ if test "x$no_glib" = x ; then
++ AC_MSG_RESULT(yes (version $glib_config_major_version.$glib_config_minor_version.$glib_config_micro_version))
++ ifelse([$2], , :, [$2])
++ else
++ AC_MSG_RESULT(no)
++ if test "$PKG_CONFIG" = "no" ; then
++ echo "*** A new enough version of pkg-config was not found."
++ echo "*** See http://www.freedesktop.org/software/pkgconfig/"
++ else
++ if test -f conf.glibtest ; then
++ :
++ else
++ echo "*** Could not run GLIB test program, checking why..."
++ ac_save_CFLAGS="$CFLAGS"
++ ac_save_LIBS="$LIBS"
++ CFLAGS="$CFLAGS $GLIB_CFLAGS"
++ LIBS="$LIBS $GLIB_LIBS"
++ AC_TRY_LINK([
++#include <glib.h>
++#include <stdio.h>
++], [ return ((glib_major_version) || (glib_minor_version) || (glib_micro_version)); ],
++ [ echo "*** The test program compiled, but did not run. This usually means"
++ echo "*** that the run-time linker is not finding GLIB or finding the wrong"
++ echo "*** version of GLIB. If it is not finding GLIB, you'll need to set your"
++ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
++ echo "*** to the installed location Also, make sure you have run ldconfig if that"
++ echo "*** is required on your system"
++ echo "***"
++ echo "*** If you have an old version installed, it is best to remove it, although"
++ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH" ],
++ [ echo "*** The test program failed to compile or link. See the file config.log for the"
++ echo "*** exact error that occured. This usually means GLIB is incorrectly installed."])
++ CFLAGS="$ac_save_CFLAGS"
++ LIBS="$ac_save_LIBS"
++ fi
++ fi
++ GLIB_CFLAGS=""
++ GLIB_LIBS=""
++ GLIB_GENMARSHAL=""
++ GOBJECT_QUERY=""
++ GLIB_MKENUMS=""
++ ifelse([$3], , :, [$3])
++ fi
++ AC_SUBST(GLIB_CFLAGS)
++ AC_SUBST(GLIB_LIBS)
++ AC_SUBST(GLIB_GENMARSHAL)
++ AC_SUBST(GOBJECT_QUERY)
++ AC_SUBST(GLIB_MKENUMS)
++ rm -f conf.glibtest
++])
+--- /dev/null
++++ pango-1.2.5/m4/glib-gettext.m4
+@@ -0,0 +1,284 @@
++# Macro to add for using GNU gettext.
++# Ulrich Drepper <drepper@cygnus.com>, 1995, 1996
++#
++# Modified to never use included libintl.
++# Owen Taylor <otaylor@redhat.com>, 12/15/1998
++#
++#
++# This file can be copied and used freely without restrictions. It can
++# be used in projects which are not available under the GNU Public License
++# but which still want to provide support for the GNU gettext functionality.
++# Please note that the actual code is *not* freely available.
++#
++#
++# If you make changes to this file, you MUST update the copy in
++# acinclude.m4. [ aclocal dies on duplicate macros, so if
++# we run 'aclocal -I macros/' then we'll run into problems
++# once we've installed glib-gettext.m4 :-( ]
++#
++
++AC_DEFUN([AM_GLIB_LC_MESSAGES],
++ [if test $ac_cv_header_locale_h = yes; then
++ AC_CACHE_CHECK([for LC_MESSAGES], am_cv_val_LC_MESSAGES,
++ [AC_TRY_LINK([#include <locale.h>], [return LC_MESSAGES],
++ am_cv_val_LC_MESSAGES=yes, am_cv_val_LC_MESSAGES=no)])
++ if test $am_cv_val_LC_MESSAGES = yes; then
++ AC_DEFINE(HAVE_LC_MESSAGES, 1,
++ [Define if your <locale.h> file defines LC_MESSAGES.])
++ fi
++ fi])
++
++dnl AM_GLIB_PATH_PROG_WITH_TEST(VARIABLE, PROG-TO-CHECK-FOR,
++dnl TEST-PERFORMED-ON-FOUND_PROGRAM [, VALUE-IF-NOT-FOUND [, PATH]])
++AC_DEFUN([AM_GLIB_PATH_PROG_WITH_TEST],
++[# Extract the first word of "$2", so it can be a program name with args.
++set dummy $2; ac_word=[$]2
++AC_MSG_CHECKING([for $ac_word])
++AC_CACHE_VAL(ac_cv_path_$1,
++[case "[$]$1" in
++ /*)
++ ac_cv_path_$1="[$]$1" # Let the user override the test with a path.
++ ;;
++ *)
++ IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS="${IFS}:"
++ for ac_dir in ifelse([$5], , $PATH, [$5]); do
++ test -z "$ac_dir" && ac_dir=.
++ if test -f $ac_dir/$ac_word; then
++ if [$3]; then
++ ac_cv_path_$1="$ac_dir/$ac_word"
++ break
++ fi
++ fi
++ done
++ IFS="$ac_save_ifs"
++dnl If no 4th arg is given, leave the cache variable unset,
++dnl so AC_PATH_PROGS will keep looking.
++ifelse([$4], , , [ test -z "[$]ac_cv_path_$1" && ac_cv_path_$1="$4"
++])dnl
++ ;;
++esac])dnl
++$1="$ac_cv_path_$1"
++if test ifelse([$4], , [-n "[$]$1"], ["[$]$1" != "$4"]); then
++ AC_MSG_RESULT([$]$1)
++else
++ AC_MSG_RESULT(no)
++fi
++AC_SUBST($1)dnl
++])
++
++# serial 5
++
++AC_DEFUN(AM_GLIB_WITH_NLS,
++ dnl NLS is obligatory
++ [USE_NLS=yes
++ AC_SUBST(USE_NLS)
++
++ dnl Figure out what method
++ nls_cv_force_use_gnu_gettext="no"
++
++ nls_cv_use_gnu_gettext="$nls_cv_force_use_gnu_gettext"
++ if test "$nls_cv_force_use_gnu_gettext" != "yes"; then
++ dnl User does not insist on using GNU NLS library. Figure out what
++ dnl to use. If gettext or catgets are available (in this order) we
++ dnl use this. Else we have to fall back to GNU NLS library.
++ dnl catgets is only used if permitted by option --with-catgets.
++ nls_cv_header_intl=
++ nls_cv_header_libgt=
++ CATOBJEXT=NONE
++ XGETTEXT=:
++
++ AC_CHECK_HEADER(libintl.h,
++ [AC_CACHE_CHECK([for dgettext in libc], gt_cv_func_dgettext_libc,
++ [AC_TRY_LINK([#include <libintl.h>], [return (int) dgettext ("","")],
++ gt_cv_func_dgettext_libc=yes, gt_cv_func_dgettext_libc=no)])
++
++ gt_cv_func_dgettext_libintl="no"
++ libintl_extra_libs=""
++
++ if test "$gt_cv_func_dgettext_libc" != "yes" ; then
++ AC_CHECK_LIB(intl, bindtextdomain,
++ [AC_CHECK_LIB(intl, dgettext,
++ gt_cv_func_dgettext_libintl=yes)])
++
++ if test "$gt_cv_func_dgettext_libc" != "yes" ; then
++ AC_MSG_CHECKING([if -liconv is needed to use gettext])
++ AC_MSG_RESULT([])
++ AC_CHECK_LIB(intl, dcgettext,
++ [gt_cv_func_dgettext_libintl=yes
++ libintl_extra_libs=-liconv],
++ :,-liconv)
++ fi
++ fi
++
++ if test "$gt_cv_func_dgettext_libintl" = "yes"; then
++ LIBS="$LIBS -lintl $libintl_extra_libs";
++ fi
++
++ if test "$gt_cv_func_dgettext_libc" = "yes" \
++ || test "$gt_cv_func_dgettext_libintl" = "yes"; then
++ AC_DEFINE(HAVE_GETTEXT,1,
++ [Define if the GNU gettext() function is already present or preinstalled.])
++ AM_GLIB_PATH_PROG_WITH_TEST(MSGFMT, msgfmt,
++ [test -z "`$ac_dir/$ac_word -h 2>&1 | grep 'dv '`"], no)dnl
++ if test "$MSGFMT" != "no"; then
++ AC_CHECK_FUNCS(dcgettext)
++ AC_PATH_PROG(GMSGFMT, gmsgfmt, $MSGFMT)
++ AM_GLIB_PATH_PROG_WITH_TEST(XGETTEXT, xgettext,
++ [test -z "`$ac_dir/$ac_word -h 2>&1 | grep '(HELP)'`"], :)
++ AC_TRY_LINK(, [extern int _nl_msg_cat_cntr;
++ return _nl_msg_cat_cntr],
++ [CATOBJEXT=.gmo
++ DATADIRNAME=share],
++ [CATOBJEXT=.mo
++ DATADIRNAME=lib])
++ INSTOBJEXT=.mo
++ fi
++ fi
++
++ # Added by Martin Baulig 12/15/98 for libc5 systems
++ if test "$gt_cv_func_dgettext_libc" != "yes" \
++ && test "$gt_cv_func_dgettext_libintl" = "yes"; then
++ INTLLIBS="-lintl $libintl_extra_libs"
++ LIBS=`echo $LIBS | sed -e 's/-lintl//'`
++ fi
++ ])
++
++ if test "$CATOBJEXT" = "NONE"; then
++ dnl Neither gettext nor catgets in included in the C library.
++ dnl Fall back on GNU gettext library.
++ nls_cv_use_gnu_gettext=yes
++ fi
++ fi
++
++ if test "$nls_cv_use_gnu_gettext" != "yes"; then
++ AC_DEFINE(ENABLE_NLS, 1,
++ [always defined to indicate that i18n is enabled])
++ else
++ dnl Unset this variable since we use the non-zero value as a flag.
++ CATOBJEXT=
++ fi
++
++ dnl Test whether we really found GNU xgettext.
++ if test "$XGETTEXT" != ":"; then
++ dnl If it is no GNU xgettext we define it as : so that the
++ dnl Makefiles still can work.
++ if $XGETTEXT --omit-header /dev/null 2> /dev/null; then
++ : ;
++ else
++ AC_MSG_RESULT(
++ [found xgettext program is not GNU xgettext; ignore it])
++ XGETTEXT=":"
++ fi
++ fi
++
++ # We need to process the po/ directory.
++ POSUB=po
++
++ AC_OUTPUT_COMMANDS(
++ [case "$CONFIG_FILES" in *po/Makefile.in*)
++ sed -e "/POTFILES =/r po/POTFILES" po/Makefile.in > po/Makefile
++ esac])
++
++ dnl These rules are solely for the distribution goal. While doing this
++ dnl we only have to keep exactly one list of the available catalogs
++ dnl in configure.in.
++ for lang in $ALL_LINGUAS; do
++ GMOFILES="$GMOFILES $lang.gmo"
++ POFILES="$POFILES $lang.po"
++ done
++
++ dnl Make all variables we use known to autoconf.
++ AC_SUBST(CATALOGS)
++ AC_SUBST(CATOBJEXT)
++ AC_SUBST(DATADIRNAME)
++ AC_SUBST(GMOFILES)
++ AC_SUBST(INSTOBJEXT)
++ AC_SUBST(INTLDEPS)
++ AC_SUBST(INTLLIBS)
++ AC_SUBST(INTLOBJS)
++ AC_SUBST(POFILES)
++ AC_SUBST(POSUB)
++ ])
++
++AC_DEFUN(AM_GLIB_GNU_GETTEXT,
++ [AC_REQUIRE([AC_PROG_MAKE_SET])dnl
++ AC_REQUIRE([AC_PROG_CC])dnl
++ AC_REQUIRE([AC_PROG_RANLIB])dnl
++ AC_REQUIRE([AC_HEADER_STDC])dnl
++ AC_REQUIRE([AC_C_CONST])dnl
++ AC_REQUIRE([AC_C_INLINE])dnl
++ AC_REQUIRE([AC_TYPE_OFF_T])dnl
++ AC_REQUIRE([AC_TYPE_SIZE_T])dnl
++ AC_REQUIRE([AC_FUNC_ALLOCA])dnl
++ AC_REQUIRE([AC_FUNC_MMAP])dnl
++
++ AC_CHECK_HEADERS([argz.h limits.h locale.h nl_types.h malloc.h string.h \
++unistd.h sys/param.h])
++ AC_CHECK_FUNCS([getcwd munmap putenv setenv setlocale strchr strcasecmp \
++strdup __argz_count __argz_stringify __argz_next])
++
++ AM_GLIB_LC_MESSAGES
++ AM_GLIB_WITH_NLS
++
++ if test "x$CATOBJEXT" != "x"; then
++ if test "x$ALL_LINGUAS" = "x"; then
++ LINGUAS=
++ else
++ AC_MSG_CHECKING(for catalogs to be installed)
++ NEW_LINGUAS=
++ for lang in ${LINGUAS=$ALL_LINGUAS}; do
++ case "$ALL_LINGUAS" in
++ *$lang*) NEW_LINGUAS="$NEW_LINGUAS $lang" ;;
++ esac
++ done
++ LINGUAS=$NEW_LINGUAS
++ AC_MSG_RESULT($LINGUAS)
++ fi
++
++ dnl Construct list of names of catalog files to be constructed.
++ if test -n "$LINGUAS"; then
++ for lang in $LINGUAS; do CATALOGS="$CATALOGS $lang$CATOBJEXT"; done
++ fi
++ fi
++
++ dnl Determine which catalog format we have (if any is needed)
++ dnl For now we know about two different formats:
++ dnl Linux libc-5 and the normal X/Open format
++ test -d po || mkdir po
++ if test "$CATOBJEXT" = ".cat"; then
++ AC_CHECK_HEADER(linux/version.h, msgformat=linux, msgformat=xopen)
++
++ dnl Transform the SED scripts while copying because some dumb SEDs
++ dnl cannot handle comments.
++ sed -e '/^#/d' $srcdir/po/$msgformat-msg.sed > po/po2msg.sed
++ fi
++
++ dnl If the AC_CONFIG_AUX_DIR macro for autoconf is used we possibly
++ dnl find the mkinstalldirs script in another subdir but ($top_srcdir).
++ dnl Try to locate is.
++ MKINSTALLDIRS=
++ if test -n "$ac_aux_dir"; then
++ MKINSTALLDIRS="$ac_aux_dir/mkinstalldirs"
++ fi
++ if test -z "$MKINSTALLDIRS"; then
++ MKINSTALLDIRS="\$(top_srcdir)/mkinstalldirs"
++ fi
++ AC_SUBST(MKINSTALLDIRS)
++
++ dnl Generate list of files to be processed by xgettext which will
++ dnl be included in po/Makefile.
++ test -d po || mkdir po
++ if test "x$srcdir" != "x."; then
++ if test "x`echo $srcdir | sed 's@/.*@@'`" = "x"; then
++ posrcprefix="$srcdir/"
++ else
++ posrcprefix="../$srcdir/"
++ fi
++ else
++ posrcprefix="../"
++ fi
++ rm -f po/POTFILES
++ sed -e "/^#/d" -e "/^\$/d" -e "s,.*, $posrcprefix& \\\\," -e "\$s/\(.*\) \\\\/\1/" \
++ < $srcdir/po/POTFILES.in > po/POTFILES
++ ])
++