summaryrefslogtreecommitdiff
path: root/packages/obsolete/compositeext
diff options
context:
space:
mode:
Diffstat (limited to 'packages/obsolete/compositeext')
-rw-r--r--packages/obsolete/compositeext/.mtn2git_empty0
-rw-r--r--packages/obsolete/compositeext/compositeext_2.0.bb16
-rw-r--r--packages/obsolete/compositeext/compositeext_cvs.bb19
3 files changed, 35 insertions, 0 deletions
diff --git a/packages/obsolete/compositeext/.mtn2git_empty b/packages/obsolete/compositeext/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/obsolete/compositeext/.mtn2git_empty
diff --git a/packages/obsolete/compositeext/compositeext_2.0.bb b/packages/obsolete/compositeext/compositeext_2.0.bb
new file mode 100644
index 0000000000..b9b634d391
--- /dev/null
+++ b/packages/obsolete/compositeext/compositeext_2.0.bb
@@ -0,0 +1,16 @@
+SECTION = "libs"
+LICENSE= "BSD-X"
+DEPENDS = "xextensions fixesext"
+DESCRIPTION = "X Composite extension headers and specification"
+
+SRC_URI = "${XLIBS_MIRROR}/compositeext-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR}
+}
diff --git a/packages/obsolete/compositeext/compositeext_cvs.bb b/packages/obsolete/compositeext/compositeext_cvs.bb
new file mode 100644
index 0000000000..8f0f4f9f46
--- /dev/null
+++ b/packages/obsolete/compositeext/compositeext_cvs.bb
@@ -0,0 +1,19 @@
+PV = "0.0+cvs${SRCDATE}"
+LICENSE= "BSD-X"
+SECTION = "libs"
+DEPENDS = "xextensions fixesext"
+DESCRIPTION = "X Composite extension headers and specification"
+DEFAULT_PREFERENCE = "1"
+
+SRC_URI = "${FREEDESKTOP_CVS}/xlibs;module=CompositeExt"
+S = "${WORKDIR}/CompositeExt"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR}
+}