summaryrefslogtreecommitdiff
path: root/packages/ntp/ntp_4.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/ntp/ntp_4.1.2.bb')
-rw-r--r--packages/ntp/ntp_4.1.2.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/packages/ntp/ntp_4.1.2.bb b/packages/ntp/ntp_4.1.2.bb
index 97bd23b196..dba8632893 100644
--- a/packages/ntp/ntp_4.1.2.bb
+++ b/packages/ntp/ntp_4.1.2.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://ntp.isc.org/bin/view/Main/WebHome"
SECTION = "console/network"
PRIORITY = "optional"
LICENSE = "ntp"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-${PV}.tar.gz \
file://configure.patch;patch=1 \
@@ -26,3 +26,17 @@ do_install_append() {
install -d ${D}/${sysconfdir}/init.d
install -m 755 ${WORKDIR}/ntpdate ${D}/${sysconfdir}/init.d
}
+
+pkg_postinst_ntpdate_nylon() {
+#!/bin/sh
+if test "x$D" == "x"; then
+ mkdir -p /etc/cron/crontabs
+ if ! grep -q ntpdate /etc/cron/crontabs/root; then
+ echo "adding crontab"
+ echo "30 * * * * /usr/bin/ntpdate -s -u pool.ntp.org" >> /etc/cron/crontabs/root
+ fi
+ update-rc.d -s busybox-cron defaults
+fi
+update-rc.d -s ntpdate defaults 30
+}
+ \ No newline at end of file