summaryrefslogtreecommitdiff
path: root/packages/nonworking
diff options
context:
space:
mode:
Diffstat (limited to 'packages/nonworking')
-rw-r--r--packages/nonworking/e17/.mtn2git_empty0
-rw-r--r--packages/nonworking/e17/evidence29
2 files changed, 29 insertions, 0 deletions
diff --git a/packages/nonworking/e17/.mtn2git_empty b/packages/nonworking/e17/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/e17/.mtn2git_empty
diff --git a/packages/nonworking/e17/evidence b/packages/nonworking/e17/evidence
new file mode 100644
index 0000000000..d1e8bd5065
--- /dev/null
+++ b/packages/nonworking/e17/evidence
@@ -0,0 +1,29 @@
+DESCRIPTION = "evidence, an enlightenemt file manager"
+LICENSE = "GPL"
+# can support dbus, avifile, libmpeg3
+DEPENDS = "pkgconfig gtk+ glib-2.0 ecore-x11 evas-x11 edb eet edje imlib2-x11 libpng epeg jpeg libpcre curl taglib libvorbis libogg libxine-x11 emotion freetype"
+RDEPENDS += "examine"
+PR = "r0"
+
+inherit e
+
+SRC_URI = "cvs://anonymous@evidence.cvs.sourceforge.net/cvsroot/evidence;module=evidence;date=${PV}"
+S = "${WORKDIR}/evidence"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --enable-ecore \
+ --enable-ecore-ipc \
+ --enable-canvas-evas2 \
+ --enable-edje \
+ --enable-x \
+ --enable-tree-view \
+ --enable-icon-view \
+ --enable-browser-view \
+ --with-libxine=${STAGING_LIBDIR}"
+
+do_compile_prepend() {
+ sed -i 's:LDFLAGS = :LDFLAGS = -L${STAGING_LIBDIR} :' ${S}/src/providers/vorbis/Makefile
+}
+
+FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} /etc/* /usr/sbin/*"
+