summaryrefslogtreecommitdiff
path: root/packages/nonworking
diff options
context:
space:
mode:
Diffstat (limited to 'packages/nonworking')
-rw-r--r--packages/nonworking/python-lxml_2.1.5.bb12
-rw-r--r--packages/nonworking/python/python-itools_0.50.1.bb12
-rw-r--r--packages/nonworking/python/python-lightmediascanner_0.2.0.bb10
-rw-r--r--packages/nonworking/python/python-mysqldb/mysqlpath.patch19
-rw-r--r--packages/nonworking/python/python-mysqldb/site.patch13
-rw-r--r--packages/nonworking/python/python-mysqldb_1.2.1.bb20
-rw-r--r--packages/nonworking/python/python-sword_1.5.10.bb32
-rw-r--r--packages/nonworking/sword/gnomesword_2.1.2.bb11
-rw-r--r--packages/nonworking/sword/sword-1.5.9/gcc-visibility.patch26
-rw-r--r--packages/nonworking/sword/sword_1.5.10.bb19
-rw-r--r--packages/nonworking/sword/sword_1.5.9.bb20
11 files changed, 194 insertions, 0 deletions
diff --git a/packages/nonworking/python-lxml_2.1.5.bb b/packages/nonworking/python-lxml_2.1.5.bb
new file mode 100644
index 0000000000..de0566e38f
--- /dev/null
+++ b/packages/nonworking/python-lxml_2.1.5.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Python Bindings to the XML libraries libxml2 and libxslt"
+HOMEPAGE = "http://codespeak.net/lxml/"
+AUTHOR = "http://codespeak.net/mailman/listinfo/lxml-dev"
+LICENSE = "BSD"
+DEPENDS = "libxml2 libxslt"
+PR = "ml0"
+
+SRC_URI = "http://codespeak.net/lxml/lxml-${PV}.tgz"
+S = "${WORKDIR}/lxml-${PV}"
+
+inherit distutils
+
diff --git a/packages/nonworking/python/python-itools_0.50.1.bb b/packages/nonworking/python/python-itools_0.50.1.bb
new file mode 100644
index 0000000000..7879c6415e
--- /dev/null
+++ b/packages/nonworking/python/python-itools_0.50.1.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "itools is a python web technologies library"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.ikaaro.org/itools"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+SRCNAME = "itools"
+PR = "ml0"
+
+SRC_URI = "http://download.ikaaro.org/itools/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
diff --git a/packages/nonworking/python/python-lightmediascanner_0.2.0.bb b/packages/nonworking/python/python-lightmediascanner_0.2.0.bb
new file mode 100644
index 0000000000..c2a337d793
--- /dev/null
+++ b/packages/nonworking/python/python-lightmediascanner_0.2.0.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "Python bindings to the Lightweight media scanner"
+SECTION = "devel/python"
+AUTHOR = "Gustavo Barbieri"
+LICENSE = "LGPL"
+DEPENDS = "lightmediascanner python-cython-native"
+PE = "1"
+
+SRC_URI = "https://garage.maemo.org/frs/download.php/4627/python-lightmediascanner-${PV}.tar.gz"
+
+inherit distutils
diff --git a/packages/nonworking/python/python-mysqldb/mysqlpath.patch b/packages/nonworking/python/python-mysqldb/mysqlpath.patch
new file mode 100644
index 0000000000..3f471a1703
--- /dev/null
+++ b/packages/nonworking/python/python-mysqldb/mysqlpath.patch
@@ -0,0 +1,19 @@
+Index: MySQL-python-1.2.1_p2/_mysql.c
+===================================================================
+--- MySQL-python-1.2.1_p2.orig/_mysql.c 2006-05-31 12:07:36.000000000 +0200
++++ MySQL-python-1.2.1_p2/_mysql.c 2006-05-31 12:08:25.000000000 +0200
+@@ -36,10 +36,10 @@
+ #endif
+
+ #include "structmember.h"
+-#include "mysql.h"
+-#include "my_config.h"
+-#include "mysqld_error.h"
+-#include "errmsg.h"
++#include "mysql/mysql.h"
++#include "mysql/my_config.h"
++#include "mysql/mysqld_error.h"
++#include "mysql/errmsg.h"
+
+ #if PY_VERSION_HEX < 0x02020000
+ # define MyTuple_Resize(t,n,d) _PyTuple_Resize(t, n, d)
diff --git a/packages/nonworking/python/python-mysqldb/site.patch b/packages/nonworking/python/python-mysqldb/site.patch
new file mode 100644
index 0000000000..c99ee3bc0d
--- /dev/null
+++ b/packages/nonworking/python/python-mysqldb/site.patch
@@ -0,0 +1,13 @@
+Index: MySQL-python-1.2.1_p2/site.cfg
+===================================================================
+--- MySQL-python-1.2.1_p2.orig/site.cfg 2006-05-31 12:13:45.000000000 +0200
++++ MySQL-python-1.2.1_p2/site.cfg 2006-05-31 12:13:55.000000000 +0200
+@@ -6,7 +6,7 @@
+
+ [options]
+ embedded = False
+-threadsafe = True
++threadsafe = False
+ static = False
+
+ # Use the compiler section to add additional options for the extension build.
diff --git a/packages/nonworking/python/python-mysqldb_1.2.1.bb b/packages/nonworking/python/python-mysqldb_1.2.1.bb
new file mode 100644
index 0000000000..9a9ca0fe56
--- /dev/null
+++ b/packages/nonworking/python/python-mysqldb_1.2.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Python interface to MySQL"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "mysql"
+SRCNAME = "MySQL-python"
+
+inherit distutils
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/mysql-python/MySQL-python-${PV}_p2.tar.gz \
+ file://mysqlpath.patch;patch=1 \
+ file://site.patch;patch=1 \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}_p2"
+
+do_install_append() {
+ install -d ${D}${datadir}/doc/${PN}/
+ install -m 0644 ${S}/doc/*.txt ${D}${datadir}/doc/${PN}/
+}
diff --git a/packages/nonworking/python/python-sword_1.5.10.bb b/packages/nonworking/python/python-sword_1.5.10.bb
new file mode 100644
index 0000000000..4769a8814f
--- /dev/null
+++ b/packages/nonworking/python/python-sword_1.5.10.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Python bindings for the sword library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python-core sword"
+DEPENDS = "sword-${PV} swig-native"
+SRCNAME = "sword"
+PR = "r0"
+
+SRC_URI = "http://crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}/bindings/swig/package"
+
+EXTRA_OECONF = "--with-sword-dir=${STAGING_DIR_HOST}${layout_exec_prefix}"
+
+inherit distutils autotools
+
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ touch ltmain.sh
+ ./autogen.sh
+}
+
+do_compile() {
+ oe_runmake BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} pythonswig python_make
+}
+
+do_install() {
+ cd ${S}/python
+ distutils_do_install
+}
diff --git a/packages/nonworking/sword/gnomesword_2.1.2.bb b/packages/nonworking/sword/gnomesword_2.1.2.bb
new file mode 100644
index 0000000000..a4ec60d040
--- /dev/null
+++ b/packages/nonworking/sword/gnomesword_2.1.2.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "GUI frontend for sword"
+HOMEPAGE = "http://gnomesword.sf.net"
+LICENSE = "GPLv3"
+DEPENDS = "gail libgnomeui gtkhtml-3.6 gail sword"
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+
diff --git a/packages/nonworking/sword/sword-1.5.9/gcc-visibility.patch b/packages/nonworking/sword/sword-1.5.9/gcc-visibility.patch
new file mode 100644
index 0000000000..f23a66767f
--- /dev/null
+++ b/packages/nonworking/sword/sword-1.5.9/gcc-visibility.patch
@@ -0,0 +1,26 @@
+diff --git a/include/rawtext.h b/include/rawtext.h
+index 32986fe..1304bf7 100644
+--- a/include/rawtext.h
++++ b/include/rawtext.h
+@@ -43,7 +43,7 @@ public:
+ virtual ~RawText();
+ virtual SWBuf &getRawEntryBuf();
+ virtual void increment(int steps = 1);
+- virtual void decrement(int steps = 1) { increment(-steps); }
++ virtual __attribute__((visibility("default"))) void decrement(int steps = 1) { increment(-steps); }
+ virtual signed char createSearchFramework(
+ void (*percent) (char, void *) = &nullPercent,
+ void *percentUserData = 0);
+diff --git a/include/versekey.h b/include/versekey.h
+index 0ca5e47..53084d9 100644
+--- a/include/versekey.h
++++ b/include/versekey.h
+@@ -253,7 +253,7 @@ public:
+ */
+ virtual const char *getText() const;
+ virtual const char *getShortText() const;
+- virtual void setText(const char *ikey) { SWKey::setText(ikey); parse (); }
++ virtual __attribute__((visibility("default"))) void setText(const char *ikey) { SWKey::setText(ikey); parse (); }
+ virtual void copyFrom(const SWKey &ikey);
+
+ /** Equates this VerseKey to another VerseKey
diff --git a/packages/nonworking/sword/sword_1.5.10.bb b/packages/nonworking/sword/sword_1.5.10.bb
new file mode 100644
index 0000000000..151bba366d
--- /dev/null
+++ b/packages/nonworking/sword/sword_1.5.10.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "The SWORD Project is an open source, cross-platform \
+(Linux, Windows, Solaris, MacOSX etc.) API and library for \
+Bible software with a constantly growing list of front-ends \
+(GUI, textmode, web-based, etc.) and a library of over 200 text modules"
+SECTION = "libs"
+HOMEPAGE = "http://www.e-sword.net/"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+
+inherit autotools pkgconfig lib_package
+
+EXTRA_OECONF = "--without-clucene --without-curl"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/packages/nonworking/sword/sword_1.5.9.bb b/packages/nonworking/sword/sword_1.5.9.bb
new file mode 100644
index 0000000000..303d7f9fcc
--- /dev/null
+++ b/packages/nonworking/sword/sword_1.5.9.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "The SWORD Project is an open source, cross-platform \
+(Linux, Windows, Solaris, MacOSX etc.) API and library for \
+Bible software with a constantly growing list of front-ends \
+(GUI, textmode, web-based, etc.) and a library of over 200 text modules"
+SECTION = "libs"
+HOMEPAGE = "http://www.e-sword.net/"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz \
+ file://gcc-visibility.patch;patch=1"
+
+inherit autotools pkgconfig lib_package
+
+EXTRA_OECONF = "--without-clucene --without-curl"
+
+do_stage() {
+ autotools_stage_all
+}