summaryrefslogtreecommitdiff
path: root/packages/nonworking/libnet/libnet_1.1.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/nonworking/libnet/libnet_1.1.2.1.bb')
-rw-r--r--packages/nonworking/libnet/libnet_1.1.2.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/nonworking/libnet/libnet_1.1.2.1.bb b/packages/nonworking/libnet/libnet_1.1.2.1.bb
index e69de29bb2..58d13c9be1 100644
--- a/packages/nonworking/libnet/libnet_1.1.2.1.bb
+++ b/packages/nonworking/libnet/libnet_1.1.2.1.bb
@@ -0,0 +1,25 @@
+#FIXME: Does not compile against linux-libc-headers 2.6
+BROKEN = "1"
+DESCRIPTION = "A packet dissection and creation library"
+SRC_URI = "http://www.packetfactory.net/libnet/dist/libnet.tar.gz \
+ file://configure.patch;patch=1 \
+ file://compile-fix.patch;patch=1"
+S = "${WORKDIR}/libnet"
+
+inherit autotools
+
+CPPFLAGS_prepend = "-I${S}/libnet/include "
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage () {
+ install -m 0755 libnet-config ${STAGING_BINDIR}/
+ oe_runmake -C src 'DESTDIR=${STAGING_DIR}/target' \
+ 'libdir=/lib' install-libLIBRARIES
+ oe_runmake -C include 'DESTDIR=${STAGING_DIR}/target' \
+ 'includedir=/include' install-includeHEADERS
+ oe_runmake -C include/libnet 'DESTDIR=${STAGING_DIR}/target' \
+ 'includedir=/include' install-libnetincludeHEADERS
+}