summaryrefslogtreecommitdiff
path: root/packages/nonworking/at76c503a
diff options
context:
space:
mode:
Diffstat (limited to 'packages/nonworking/at76c503a')
-rw-r--r--packages/nonworking/at76c503a/.mtn2git_empty0
-rw-r--r--packages/nonworking/at76c503a/at76c503a-modules/.mtn2git_empty0
-rw-r--r--packages/nonworking/at76c503a/at76c503a-modules/makefile.cc.patch11
-rw-r--r--packages/nonworking/at76c503a/at76c503a-modules_0.17.bb22
-rw-r--r--packages/nonworking/at76c503a/at76c503a-modules_cvs.bb23
5 files changed, 56 insertions, 0 deletions
diff --git a/packages/nonworking/at76c503a/.mtn2git_empty b/packages/nonworking/at76c503a/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/at76c503a/.mtn2git_empty
diff --git a/packages/nonworking/at76c503a/at76c503a-modules/.mtn2git_empty b/packages/nonworking/at76c503a/at76c503a-modules/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/nonworking/at76c503a/at76c503a-modules/.mtn2git_empty
diff --git a/packages/nonworking/at76c503a/at76c503a-modules/makefile.cc.patch b/packages/nonworking/at76c503a/at76c503a-modules/makefile.cc.patch
new file mode 100644
index 0000000000..c7a41990d3
--- /dev/null
+++ b/packages/nonworking/at76c503a/at76c503a-modules/makefile.cc.patch
@@ -0,0 +1,11 @@
+--- at76c503a/Makefile.old 2005-07-29 21:57:34.000000000 +0200
++++ at76c503a/Makefile 2005-07-29 21:57:43.000000000 +0200
+@@ -9,7 +9,7 @@
+ # the License, or (at your option) any later version.
+ #
+
+-CC=gcc
++#CC=gcc
+
+ ifneq (,$(KVERS))
+ KERNEL_VERSION=$(KVERS)
diff --git a/packages/nonworking/at76c503a/at76c503a-modules_0.17.bb b/packages/nonworking/at76c503a/at76c503a-modules_0.17.bb
new file mode 100644
index 0000000000..58b782b483
--- /dev/null
+++ b/packages/nonworking/at76c503a/at76c503a-modules_0.17.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Driver for at76 based usb-wifi devices"
+SECTION = "base"
+LICENSE = "GPL"
+
+PR = "r1"
+
+RDEPENDS = "at76c503-firmware"
+
+SRC_URI = "http://download.berlios.de/at76c503a/at76_usb-0.17.tar.gz"
+S = "${WORKDIR}/at76_usb-${PV}/"
+
+inherit module
+
+MODULES = "at76c503 at76_usbdfu at76c503-i3861 at76c503-rfmd at76c503-rfmd-acc \
+ at76c505-rfmd at76c503-i3863 at76c505-rfmd2958"
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
+ for i in *${KERNEL_OBJECT_SUFFIX}; do
+ install -m 0644 $i ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
+ done
+}
diff --git a/packages/nonworking/at76c503a/at76c503a-modules_cvs.bb b/packages/nonworking/at76c503a/at76c503a-modules_cvs.bb
new file mode 100644
index 0000000000..7422cc610c
--- /dev/null
+++ b/packages/nonworking/at76c503a/at76c503a-modules_cvs.bb
@@ -0,0 +1,23 @@
+SECTION = "base"
+LICENSE = "GPL"
+SRC_URI = "cvs://anonymous@cvs.berlios.de/cvsroot/at76c503a;module=at76c503a \
+ file://makefile.cc.patch;patch=1"
+S = "${WORKDIR}/at76c503a"
+PR = "r4"
+PV = "0.0+cvs${SRCDATE}"
+
+inherit module
+
+MODULES = "at76c503 at76_usbdfu at76c503-i3861 at76c503-rfmd at76c503-rfmd-acc \
+ at76c505-rfmd at76c503-i3863 at76c505-rfmd2958"
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
+ for i in ${MODULES}; do
+ install -m 0644 $i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/
+ done
+ if [ "${MACHINE}" = "h3900" ]; then
+ install -d ${D}${sysconfdir}/modutils
+ echo "at76c503-rfmd" > ${D}${sysconfdir}/modutils/at76c503-rfmd
+ fi
+}