summaryrefslogtreecommitdiff
path: root/packages/nano
diff options
context:
space:
mode:
Diffstat (limited to 'packages/nano')
-rw-r--r--packages/nano/nano_1.2.1.bb16
-rw-r--r--packages/nano/nano_1.3.5.bb16
2 files changed, 32 insertions, 0 deletions
diff --git a/packages/nano/nano_1.2.1.bb b/packages/nano/nano_1.2.1.bb
index e69de29bb2..9ff3e899d9 100644
--- a/packages/nano/nano_1.2.1.bb
+++ b/packages/nano/nano_1.2.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "GNU nano (Nano's ANOther editor, or \
+Not ANOther editor) is an enhanced clone of the \
+Pico text editor."
+LICENSE = GPL
+SECTION = "console/utils"
+DEPENDS = "ncurses"
+
+SRC_URI = "${GNU_MIRROR}/nano/nano-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://glib.m4"
+
+inherit autotools
+
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/glib.m4 m4/
+}
diff --git a/packages/nano/nano_1.3.5.bb b/packages/nano/nano_1.3.5.bb
index e69de29bb2..c82f5e2327 100644
--- a/packages/nano/nano_1.3.5.bb
+++ b/packages/nano/nano_1.3.5.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "GNU nano (Nano's ANOther editor, or \
+Not ANOther editor) is an enhanced clone of the \
+Pico text editor."
+HOMEPAGE = "http://www.nano-editor.org/"
+LICENSE = "GPLv2"
+SECTION = "console/utils"
+DEPENDS = "ncurses"
+
+SRC_URI = "http://www.nano-editor.org/dist/v1.3/nano-${PV}.tar.gz \
+ file://glib.m4"
+
+inherit autotools
+
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/glib.m4 m4/
+}