summaryrefslogtreecommitdiff
path: root/packages/mplayer/mplayer_1.0pre8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/mplayer/mplayer_1.0pre8.bb')
-rw-r--r--packages/mplayer/mplayer_1.0pre8.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/packages/mplayer/mplayer_1.0pre8.bb b/packages/mplayer/mplayer_1.0pre8.bb
new file mode 100644
index 0000000000..a55c59dc96
--- /dev/null
+++ b/packages/mplayer/mplayer_1.0pre8.bb
@@ -0,0 +1,71 @@
+DESCRIPTION = "Open Source multimedia player."
+SECTION = "opie/multimedia"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.mplayerhq.hu/"
+DEPENDS = "virtual/libsdl libmad zlib libpng jpeg mplayer-common"
+RDEPENDS = "mplayer-common"
+LICENSE = "GPL"
+SRC_URI = "http://www1.mplayerhq.hu/MPlayer/releases/MPlayer-${PV}.tar.bz2 \
+ file://vo_w100.c \
+ file://vo_w100_api.h \
+ file://vo_w100_fb.h \
+ file://Makefile.patch;patch=1 \
+ file://w100-configure.patch;patch=1 \
+ file://w100-Makefile.patch;patch=1 \
+ file://w100-video_out.patch;patch=1 \
+ file://w100-mplayer.patch;patch=1"
+
+MAINTAINER="Graeme Gregory <dp@xora.org.uk>"
+RCONFLICTS_${PN} = "mplayer-atty"
+RREPLACES_${PN} = "mplayer-atty"
+PR = "r0"
+
+PARALLEL_MAKE = ""
+
+DEPENDS_append_c7x0 = " sharp-aticore-oss"
+
+S = "${WORKDIR}/MPlayer-${PV}"
+
+PACKAGES =+ "mencoder"
+
+FILES_${PN} = "${bindir}/mplayer"
+FILES_mencoder = "${bindir}/mencoder"
+
+inherit autotools
+
+EXTRA_OECONF = " \
+ --prefix=/usr \
+ --mandir=${mandir} \
+ --target=${TARGET_SYS} \
+ \
+ --enable-mencoder \
+ --disable-gui \
+ --enable-largefiles \
+ --disable-linux-devfs \
+ --disable-lirc \
+ --disable-lircc \
+ --disable-tv \
+ --enable-rtc \
+ --disable-smb \
+ --disable-win32 \
+ \
+ --enable-tremor-low \
+ --disable-mp3lib \
+ \
+ --disable-x11 \
+ --enable-sdl \
+ --enable-fbdev "
+
+EXTRA_OECONF_append_c7x0 = " --enable-w100 "
+
+do_configure() {
+ cp ${WORKDIR}/vo_w100.c ${S}/libvo
+ cp ${WORKDIR}/vo_w100_api.h ${S}/libvo
+ cp ${WORKDIR}/vo_w100_fb.h ${S}/libvo
+ ./configure ${EXTRA_OECONF}
+}
+
+do_compile () {
+ oe_runmake
+}
+