summaryrefslogtreecommitdiff
path: root/packages/mplayer/files/libfaad-fixed.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/mplayer/files/libfaad-fixed.patch')
-rw-r--r--packages/mplayer/files/libfaad-fixed.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/mplayer/files/libfaad-fixed.patch b/packages/mplayer/files/libfaad-fixed.patch
new file mode 100644
index 0000000000..2b85179038
--- /dev/null
+++ b/packages/mplayer/files/libfaad-fixed.patch
@@ -0,0 +1,16 @@
+--- mplayer-1.1.5/libfaad2/Makefile.orig 2006-05-12 14:45:49.000000000 +0100
++++ mplayer-1.1.5/libfaad2/Makefile 2006-05-12 14:46:36.000000000 +0100
+@@ -6,11 +6,11 @@
+ SRCS = bits.c cfft.c common.c decoder.c drc.c error.c filtbank.c hcr.c huffman.c ic_predict.c is.c lt_predict.c mdct.c mp4.c ms.c output.c pns.c ps_dec.c ps_syntax.c pulse.c rvlc.c sbr_dct.c sbr_dec.c sbr_e_nf.c sbr_fbt.c sbr_hfadj.c sbr_hfgen.c sbr_huff.c sbr_qmf.c sbr_syntax.c sbr_tf_grid.c specrec.c ssr.c ssr_fb.c ssr_ipqf.c syntax.c tns.c
+ OBJS = $(SRCS:.c=.o)
+
+-CFLAGS = -I. $(OPTFLAGS)
++#CFLAGS = -I. $(OPTFLAGS)
+
+ # Uncomment this to use the FIXED_POINT implementation of FAAD2.
+ # This should improve performance, especially for SBR files.
+-#CFLAGS = -I. $(OPTFLAGS) -DFIXED_POINT
++CFLAGS = -I. $(OPTFLAGS) -DFIXED_POINT
+
+ .SUFFIXES: .c .o
+