summaryrefslogtreecommitdiff
path: root/packages/mozilla/firefox_1.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/mozilla/firefox_1.0.6.bb')
-rw-r--r--packages/mozilla/firefox_1.0.6.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/mozilla/firefox_1.0.6.bb b/packages/mozilla/firefox_1.0.6.bb
new file mode 100644
index 0000000000..4a7b79454c
--- /dev/null
+++ b/packages/mozilla/firefox_1.0.6.bb
@@ -0,0 +1,20 @@
+PR = "r0"
+SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
+ file://xptcstubs.patch;patch=1 \
+ file://no-xmb.patch;patch=1 \
+ file://firefox-cc-fix.patch;patch=1 \
+ file://jsautocfg.h \
+ file://extensions-hack.patch;patch=1"
+
+S = "${WORKDIR}/mozilla"
+
+EXCLUDE_FROM_SHLIBS = "1"
+
+inherit mozilla
+
+include firefox.inc
+
+do_compile_prepend() {
+ cp ${WORKDIR}/jsautocfg.h ${S}/js/src/
+}
+