summaryrefslogtreecommitdiff
path: root/packages/monotone
diff options
context:
space:
mode:
Diffstat (limited to 'packages/monotone')
-rw-r--r--packages/monotone/.mtn2git_empty0
-rw-r--r--packages/monotone/files/.mtn2git_empty0
-rw-r--r--packages/monotone/files/cryptopp-endianness.patch24
-rw-r--r--packages/monotone/files/txt2c-cross.patch15
-rw-r--r--packages/monotone/monotone_0.19.bb38
-rw-r--r--packages/monotone/monotone_0.20.bb37
6 files changed, 114 insertions, 0 deletions
diff --git a/packages/monotone/.mtn2git_empty b/packages/monotone/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/monotone/.mtn2git_empty
diff --git a/packages/monotone/files/.mtn2git_empty b/packages/monotone/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/monotone/files/.mtn2git_empty
diff --git a/packages/monotone/files/cryptopp-endianness.patch b/packages/monotone/files/cryptopp-endianness.patch
new file mode 100644
index 0000000000..7abfa7cda1
--- /dev/null
+++ b/packages/monotone/files/cryptopp-endianness.patch
@@ -0,0 +1,24 @@
+--- intel-0.19/cryptopp/config.h.orig 2005-07-05 22:35:21.352503986 -0700
++++ intel-0.19/cryptopp/config.h 2005-07-05 22:35:24.303056731 -0700
+@@ -5,6 +5,13 @@
+
+ // ***************** Important Settings ********************
+
++#if defined(__BYTE_ORDER) && defined(__LITTLE_ENDIAN) && defined(__BIG_ENDIAN)
++# if __BYTE_ORDER == __LITTLE_ENDIAN
++# define IS_LITTLE_ENDIAN
++# elif __BYTE_ORDER == __BIG_ENDIAN
++# define IS_BIG_ENDIAN
++# endif
++#else
+ // define this if running on a big-endian CPU
+ #if !defined(IS_LITTLE_ENDIAN) && (defined(__BIG_ENDIAN__) || defined(__sparc) || defined(__sparc__) || defined(__hppa__) || defined(__mips__) || (defined(__MWERKS__) && !defined(__INTEL__)))
+ # define IS_BIG_ENDIAN
+@@ -15,6 +22,7 @@
+ #ifndef IS_BIG_ENDIAN
+ # define IS_LITTLE_ENDIAN
+ #endif
++#endif /* Linux endiannes macros not defined */
+
+ // define this if you want to disable all OS-dependent features,
+ // such as sockets and OS-provided random number generators
diff --git a/packages/monotone/files/txt2c-cross.patch b/packages/monotone/files/txt2c-cross.patch
new file mode 100644
index 0000000000..a50b8135fc
--- /dev/null
+++ b/packages/monotone/files/txt2c-cross.patch
@@ -0,0 +1,15 @@
+# txt2c runs (only) on the build system. This is a fairly horrible
+# hack to make it compile with the build system compiler, not the
+# target compiler.
+
+--- monotone-0.19/Makefile.am.orig 2005-07-04 23:39:44.420722558 -0700
++++ monotone-0.19/Makefile.am 2005-07-04 23:36:50.267121331 -0700
+@@ -356,7 +356,7 @@
+ CLEANFILES = $(BUILT_SOURCES_CLEAN) $(EPS_FIGURES)
+
+ txt2c: txt2c.cc Makefile
+- $(CXX) -Wall -o $@ $<
++ $(BUILD_CXX) -Wall -o $@ $<
+ chmod 0755 $@$(EXEEXT)
+
+ apidocs:
diff --git a/packages/monotone/monotone_0.19.bb b/packages/monotone/monotone_0.19.bb
new file mode 100644
index 0000000000..3faad29b41
--- /dev/null
+++ b/packages/monotone/monotone_0.19.bb
@@ -0,0 +1,38 @@
+# This package builds the devio program
+DESCRIPTION = "monotone - an SCM"
+HOMEPAGE = "http://www.venge.net/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+SUBV = "1"
+PR = "r1"
+
+SRC_URI = "http://www.venge.net/monotone/downloads/monotone_${PV}-${SUBV}.tar.gz \
+ file://txt2c-cross.patch;patch=1 \
+ file://cryptopp-endianness.patch;patch=1"
+DEPENDS += "boost"
+# Following may be required, not proved yet...
+#TARGET_CFLAGS += "-fno-strict-aliasing"
+
+PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
+tsd = "/home/monotone"
+FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+
+# no cross compile support - it tries to run the test program even with
+# --enable_ipv6=yes
+EXTRA_OECONF = "--disable-ipv6 \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-nls \
+ --with-gnu-ld \
+ "
+
+inherit autotools
+
+# This makes the testsuite as a package
+do_install_append() {
+ install -d ${D}${tsd}
+ install -c -m 755 testsuite ${D}${tsd}/testsuite
+ cp -a tests ${D}${tsd}/tests
+}
diff --git a/packages/monotone/monotone_0.20.bb b/packages/monotone/monotone_0.20.bb
new file mode 100644
index 0000000000..dc7abc72b4
--- /dev/null
+++ b/packages/monotone/monotone_0.20.bb
@@ -0,0 +1,37 @@
+# This package builds the devio program
+DESCRIPTION = "monotone - an SCM"
+HOMEPAGE = "http://www.venge.net/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PR = "r0"
+
+SRC_URI = "http://venge.net/monotone/downloads/monotone-${PV}.tar.gz \
+ file://txt2c-cross.patch;patch=1 \
+ file://cryptopp-endianness.patch;patch=1"
+DEPENDS += "boost"
+# Following may be required, not proved yet...
+#TARGET_CFLAGS += "-fno-strict-aliasing"
+
+PACKAGES = "${PN} ${PN}-doc ${PN}-testsuite"
+tsd = "/home/monotone"
+FILES_${PN}-testsuite = "${tsd}/testsuite ${tsd}/tests"
+
+# no cross compile support - it tries to run the test program even with
+# --enable_ipv6=yes
+EXTRA_OECONF = "--disable-ipv6 \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-nls \
+ --with-gnu-ld \
+ "
+
+inherit autotools
+
+# This makes the testsuite as a package
+do_install_append() {
+ install -d ${D}${tsd}
+ install -c -m 755 testsuite ${D}${tsd}/testsuite
+ cp -a tests ${D}${tsd}/tests
+}